summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2024-02-27 16:40:09 +0300
committerCaleb Maclennan2024-02-27 16:40:09 +0300
commit5a2cf736f7c14d3c800dc22002f6a2e9dbb166b9 (patch)
tree1499b494d193f23844ef274428b6a031484db5bb
downloadaur-5a2cf736f7c14d3c800dc22002f6a2e9dbb166b9.tar.gz
Initial upload: yage 0.5.0-1
-rw-r--r--.SRCINFO19
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD42
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fee9890af91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = yage
+ pkgdesc = manage encrypted secrets in YAML files with age encryption
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/glehmann/yage
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = cargo
+ depends = gcc-libs
+ depends = glibc
+ source = https://github.com/glehmann/yage/archive/0.5.0/yage-0.5.0.tar.gz
+ sha256sums = 76a7a8bd546622b02896e9cdc585fe4bbfdf7fdddf8218a73c748740966474ca
+
+pkgname = yage
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..26ae26e9ae22
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[yage]
+source = "github"
+github = "glehmann/yage"
+use_max_tag = true
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4dabb26f22d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=yage
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='manage encrypted secrets in YAML files with age encryption'
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
+url="https://github.com/glehmann/$pkgname"
+license=(MIT)
+depends=(gcc-libs
+ glibc)
+makedepends=(cargo)
+_archive="$pkgname-$pkgver"
+source=("$url/archive/$pkgver/$_archive.tar.gz")
+sha256sums=('76a7a8bd546622b02896e9cdc585fe4bbfdf7fdddf8218a73c748740966474ca')
+
+prepare() {
+ cd "$_archive"
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+_srcenv() {
+ cd "$_archive"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+}
+
+build() {
+ _srcenv
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ _srcenv
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$_archive"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+}