summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-07-04 19:29:40 +0100
committerJoão Figueiredo2021-07-04 19:29:40 +0100
commit2dfc9972ef85cbcb609f0469a38a5443abb118c4 (patch)
treed720cbdf7842f7f59da44a9c121818843d51cf51
parent758b2314f4f69d069ea2198d1c39c25960247901 (diff)
downloadaur-2dfc9972ef85cbcb609f0469a38a5443abb118c4.tar.gz
Merged with official ABS yakuake PKGBUILD
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 33 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 516099b3283a..32c6f18d3679 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = yakuake-git
- pkgdesc = A drop-down terminal emulator based on KDE konsole technology
- pkgver = 20.04.2.r40.g946ecc7
+ pkgdesc = A drop-down terminal emulator based on KDE konsole-git technology
+ pkgver = 21.07.70_r722.g0eb3a30
pkgrel = 1
- url = https://kde.org/applications/system/org.kde.yakuake
+ url = https://apps.kde.org/yakuake/
arch = x86_64
- groups = kde-applications
- groups = kde-utilities
- license = GPL2
- makedepends = extra-cmake-modules
+ groups = kde-applications-git
+ groups = kde-utilities-git
+ license = GPL
makedepends = git
+ makedepends = extra-cmake-modules-git
+ depends = konsole-git
+ depends = kwayland-git
depends = hicolor-icon-theme
- depends = konsole
- depends = kwayland
provides = yakuake
- source = git+https://invent.kde.org/utilities/yakuake.git
+ conflicts = yakuake
+ source = git+https://github.com/KDE/yakuake.git
sha256sums = SKIP
pkgname = yakuake-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c663eb6df85d..e9886cba547b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,37 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Merged with official ABS yakuake PKGBUILD by João, 2021/07/04 (all respective contributors apply herein)
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
-_pkgname=yakuake
-pkgname=${_pkgname}-git
-pkgver=20.04.2.r40.g946ecc7
+pkgname=yakuake-git
+pkgver=21.07.70_r722.g0eb3a30
pkgrel=1
-pkgdesc='A drop-down terminal emulator based on KDE konsole technology'
-arch=('x86_64')
-url='https://kde.org/applications/system/org.kde.yakuake'
-license=('GPL2')
-groups=('kde-applications' 'kde-utilities')
-depends=('hicolor-icon-theme' 'konsole' 'kwayland')
-makedepends=('extra-cmake-modules' 'git')
-provides=("${_pkgname}")
-source=("git+https://invent.kde.org/utilities/${_pkgname}.git")
+pkgdesc='A drop-down terminal emulator based on KDE konsole-git technology'
+arch=($CARCH)
+url='https://apps.kde.org/yakuake/'
+license=(GPL)
+depends=(konsole-git kwayland-git hicolor-icon-theme)
+makedepends=(git extra-cmake-modules-git)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+groups=(kde-applications-git kde-utilities-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
- git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd ${pkgname%-git}
+ _major_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MAJOR' CMakeLists.txt | cut -d '"' -f2)"
+ _minor_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MINOR' CMakeLists.txt | cut -d '"' -f2)"
+ _micro_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MICRO' CMakeLists.txt | cut -d '"' -f2)"
+ echo "${_major_ver}.${_minor_ver}.${_micro_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cmake -B build -S "${_pkgname}" \
+ cmake -B build -S ${pkgname%-git} \
-DBUILD_TESTING=OFF
cmake --build build
}
package() {
- DESTDIR="${pkgdir}" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build
}
-
-# vim: ts=2 sw=2 et: