summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-03-02 16:12:30 +0100
committerGustavo Alvarez2016-03-02 16:12:30 +0100
commite2f61818d50c57309a061bc68991cf50056dac46 (patch)
tree5735dccd82d0a3bb5b7f3f96db4dfcd88f0dffdb
downloadaur-e2f61818d50c57309a061bc68991cf50056dac46.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD46
-rw-r--r--yakuake-git.install12
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3217bd71ce31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Wed Mar 2 15:12:30 UTC 2016
+pkgbase = yakuake-git
+ pkgdesc = A drop-down terminal emulator based on KDE Konsole technology. (GIT version)
+ pkgver = v2.9.9.153.g652a0fb
+ pkgrel = 1
+ url = https://www.kde.org/applications/system/yakuake
+ install = yakuake-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = python
+ depends = knewstuff
+ depends = konsole
+ depends = hicolor-icon-theme
+ provides = yakuake
+ conflicts = yakuake
+ source = git://anongit.kde.org/yakuake.git
+ sha1sums = SKIP
+
+pkgname = yakuake-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8ec3a2a78d2c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!yakuake-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f67bc7cb49d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=yakuake-git
+pkgver=v2.9.9.153.g652a0fb
+pkgrel=1
+pkgdesc="A drop-down terminal emulator based on KDE Konsole technology. (GIT version)"
+arch=('i686' 'x86_64')
+url='https://www.kde.org/applications/system/yakuake'
+license=('GPL')
+depends=('knewstuff'
+ 'konsole'
+ 'hicolor-icon-theme'
+ )
+makedepends=('extra-cmake-modules'
+ 'git'
+ 'python'
+ )
+conflicts=('yakuake')
+provides=('yakuake')
+source=('git://anongit.kde.org/yakuake.git')
+sha1sums=('SKIP')
+install=yakuake-git.install
+
+pkgver() {
+ cd yakuake
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../yakuake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/yakuake-git.install b/yakuake-git.install
new file mode 100644
index 000000000000..987eb70a1093
--- /dev/null
+++ b/yakuake-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file