summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-04-02 10:51:00 +0200
committerAlexander F. Rødseth2019-04-02 10:51:00 +0200
commit46da1404a60fc7c1e56c6ccc81fbac82dda48b05 (patch)
tree941c90fc9a76cbfa7561c0b1c864f2192b7dc181
downloadaur-46da1404a60fc7c1e56c6ccc81fbac82dda48b05.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e54f457762fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Apr 2 08:50:48 UTC 2019
+pkgbase = yaloco
+ pkgdesc = Yet Another Log Colorizer
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/xyproto/yaloco
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ source = git+https://github.com/xyproto/yaloco#tag=v1.2.0
+ md5sums = SKIP
+
+pkgname = yaloco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2644b778f9be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=yaloco
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Yet Another Log Colorizer'
+arch=(x86_64)
+url='https://github.com/xyproto/yaloco'
+license=(MIT)
+makedepends=(git go)
+source=("git+$url#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+
+ go build .
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: