summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStavros Polymenis2015-07-11 15:25:05 +0100
committerStavros Polymenis2015-07-11 15:25:05 +0100
commit1248826109bdd9376e4ff10676ee51b01eff9437 (patch)
tree2138c7ea5d692ae435f40d15e0d018bba1ec510d
downloadaur-1248826109bdd9376e4ff10676ee51b01eff9437.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d456057131bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = yamado-git
+ pkgdesc = Yamado is a minimal note & journal system with extensions for functioning as a homepage & blog.
+ pkgver = 150707alpha
+ pkgrel = 2
+ url = http://lc.orbitalfox.com
+ arch = any
+ groups = portal
+ license = GPL
+ depends = markdown
+ source = git+https://github.com/orbifx/yamado.git
+ md5sums = SKIP
+
+pkgname = yamado-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae33c2f048d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+#Maintainer: Stavros Polymenis <sp orbitalfox.com>
+pkgname=yamado-git
+pkgver=150708beta
+pkgrel=1
+pkgdesc="Yamado is a minimal note & journal system with extensions for functioning as a homepage & blog."
+arch=(any)
+url="http://lc.orbitalfox.com"
+license=('AGPL3')
+groups=(portal)
+depends=(markdown)
+makedepends=(git)
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(git+https://github.com/orbifx/yamado.git)
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+
+# ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" install
+}