summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2022-04-09 19:54:53 +0200
committerCarsten Teibes2022-04-09 19:54:53 +0200
commit4a5a86361c9c1f3e1cc630998bdf77bddf48b6c9 (patch)
treea31b6fb341fb2a701db71676b7115ac3d238bd8f
parent50601ce49d70b80e110b799db951228d0e2afdd2 (diff)
downloadaur-4a5a86361c9c1f3e1cc630998bdf77bddf48b6c9.tar.gz
[upd] 8.00→8.01
[fix] back from CMake to Makefile, since former is unsupported.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
2 files changed, 16 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b98d47796dd0..8b263cf6960b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = yamagi-quake2
pkgdesc = Enhanced Quake II engine optimized for modern systems
- pkgver = 8.00
+ pkgver = 8.01
pkgrel = 1
- url = http://www.yamagi.org/quake2/
+ url = https://www.yamagi.org/quake2/
install = yamagi-quake2.install
arch = i686
arch = x86_64
arch = aarch64
license = custom: Info-ZIP
license = GPL2
- makedepends = cmake
- makedepends = ninja
makedepends = openal
makedepends = mesa
makedepends = curl
@@ -18,9 +16,9 @@ pkgbase = yamagi-quake2
optdepends = quake2-demo: shareware data files
optdepends = openal: alternative audio backend
optdepends = curl: http download support
- source = https://deponie.yamagi.org/quake2/quake2-8.00.tar.xz
+ source = https://deponie.yamagi.org/quake2/quake2-8.01.tar.xz
source = yamagi-quake2.desktop
- sha256sums = 60d8d10fc2b4d75b961251990e4d903357194a73210bc1e42924edef887d0eb2
+ sha256sums = 132889a6976dd7c75bf94a4ca49c76ff09cf843d66541872320d7a02a25a622c
sha256sums = 7049a1798e38a263fb2660b94fb70f5154fad1f807259d41649e12cea1a6757c
pkgname = yamagi-quake2
diff --git a/PKGBUILD b/PKGBUILD
index c16afcd1b1b4..f91ea228a0c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,60 +2,50 @@
# Contributors: Frederic Bezies, Ronan Rabouin
pkgname=yamagi-quake2
-pkgver=8.00
+pkgver=8.01
pkgrel=1
pkgdesc="Enhanced Quake II engine optimized for modern systems"
-url="http://www.yamagi.org/quake2/"
+url="https://www.yamagi.org/quake2/"
arch=('i686' 'x86_64' 'aarch64')
license=('custom: Info-ZIP' 'GPL2')
depends=('sdl2')
optdepends=('quake2-demo: shareware data files'
'openal: alternative audio backend'
'curl: http download support')
-makedepends=('cmake' 'ninja' 'openal' 'mesa' 'curl')
+makedepends=('openal' 'mesa' 'curl')
install=$pkgname.install
source=("https://deponie.yamagi.org/quake2/quake2-$pkgver.tar.xz"
"$pkgname.desktop")
-sha256sums=('60d8d10fc2b4d75b961251990e4d903357194a73210bc1e42924edef887d0eb2'
+sha256sums=('132889a6976dd7c75bf94a4ca49c76ff09cf843d66541872320d7a02a25a622c'
'7049a1798e38a263fb2660b94fb70f5154fad1f807259d41649e12cea1a6757c')
build() {
- rm -rf build
- cmake quake2-$pkgver -Bbuild \
- -DCMAKE_BUILD_TYPE=Release \
- -DSYSTEMWIDE_SUPPORT=ON \
- -GNinja
- cmake --build build
+ make -C quake2-$pkgver WITH_RPATH=no WITH_SYSTEMWIDE=yes
}
package() {
- cd build
+ cd quake2-$pkgver
- # client + server binaries
- install -Dm755 release/quake2 "$pkgdir"/usr/lib/$pkgname/quake2
- install -m755 release/q2ded "$pkgdir"/usr/lib/$pkgname
+ # client + server binaries, renderer libraries
+ install -Dm755 -t "$pkgdir"/usr/lib/$pkgname release/{quake2,q2ded,*.so}
# symlinks to make the commands available
install -d "$pkgdir"/usr/bin
ln -s /usr/lib/$pkgname/quake2 "$pkgdir"/usr/bin/$pkgname
ln -s /usr/lib/$pkgname/q2ded "$pkgdir"/usr/bin/yamagi-q2ded
- # game libraries
- install -m644 release/*.so "$pkgdir"/usr/lib/$pkgname
- install -Dm644 release/baseq2/game.so "$pkgdir"/usr/lib/$pkgname/baseq2/game.so
+ # game library
+ install -Dm644 -t "$pkgdir"/usr/lib/$pkgname/baseq2 release/baseq2/game.so
# shared game directory
install -d "$pkgdir"/usr/share/games/quake2
echo "You can put Quake 2 game files here." > "$pkgdir"/usr/share/games/quake2/README
- cd ../quake2-$pkgver
-
# doc
- install -Dm644 stuff/yq2.cfg "$pkgdir"/usr/share/doc/$pkgname/yq2.cfg
- install -m644 doc/*.md "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm644 -t "$pkgdir"/usr/share/doc/$pkgname stuff/yq2.cfg doc/*.md
# desktop entry
- install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/applications ../$pkgname.desktop
install -Dm644 stuff/icon/Quake2.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
# licenses