summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-01-24 03:28:51 +0100
committerCarsten Teibes2014-01-24 03:28:51 +0100
commit74f0a964b4aa23ebebe1496c2cf9c32c20166400 (patch)
treef3f15e7d75417db63cf0838e8ce5fa604f9a88b8
downloadaur-74f0a964b4aa23ebebe1496c2cf9c32c20166400.tar.gz
[add] yamagi-quake2-rogue 1.07
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
-rw-r--r--yamagi-quake2-rogue.ChangeLog7
-rw-r--r--yamagi-quake2-rogue.desktop10
-rw-r--r--yamagi-quake2-rogue.install9
-rw-r--r--yamagi-quake2-rogue.sh3
6 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22178613d990
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = yamagi-quake2-rogue
+ pkgdesc = Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2
+ pkgver = 1.07
+ pkgrel = 2
+ url = http://www.yamagi.org/quake2/
+ install = yamagi-quake2-rogue.install
+ changelog = yamagi-quake2-rogue.ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ depends = sh
+ depends = yamagi-quake2
+ source = http://deponie.yamagi.org/quake2/quake2-rogue-1.07.tar.xz
+ source = yamagi-quake2-rogue.sh
+ source = yamagi-quake2-rogue.desktop
+ sha256sums = 0b97d24ab11663abff752c73d0f87c9ce635454de396d2e6a5deb3a4ec36244d
+ sha256sums = 7d43bd0ca15a6c82560153deea1df1109d0a448b226e316b6b7b5daae256241a
+ sha256sums = b0347a6571748b5c1176e12b7a04f0b10e982c973bc6b7c749861146bf4d05a6
+
+pkgname = yamagi-quake2-rogue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..908eaa24dad9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: Frederic Bezies <fredbezies@gmail.com>
+# Contributor: Ronan Rabouin <darkbaboon@gmail.com>
+
+_pkgbase=quake2-rogue
+pkgname=yamagi-$_pkgbase
+pkgver=1.07
+pkgrel=2
+arch=('i686' 'x86_64')
+pkgdesc="Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2"
+url="http://www.yamagi.org/quake2/"
+license=('GPL' 'custom')
+depends=('sh' 'yamagi-quake2')
+install=$pkgname.install
+changelog=$pkgname.ChangeLog
+source=("http://deponie.yamagi.org/quake2/$_pkgbase-$pkgver.tar.xz"
+ "$pkgname.sh" "$pkgname.desktop")
+sha256sums=('0b97d24ab11663abff752c73d0f87c9ce635454de396d2e6a5deb3a4ec36244d'
+ '7d43bd0ca15a6c82560153deea1df1109d0a448b226e316b6b7b5daae256241a'
+ 'b0347a6571748b5c1176e12b7a04f0b10e982c973bc6b7c749861146bf4d05a6')
+
+build() {
+ cd $_pkgbase-$pkgver
+
+ make
+}
+
+package() {
+ cd $_pkgbase-$pkgver
+
+ # game launcher
+ install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
+
+ # game library
+ install -Dm644 release/game.so "$pkgdir"/usr/share/yamagi-quake2/rogue/game.so
+
+ # doc
+ install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+
+ # desktop entry
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ # license
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/yamagi-quake2-rogue.ChangeLog b/yamagi-quake2-rogue.ChangeLog
new file mode 100644
index 000000000000..388d837af78d
--- /dev/null
+++ b/yamagi-quake2-rogue.ChangeLog
@@ -0,0 +1,7 @@
+2014-01-24 carstene1ns <url/mail: arch carsten-teibes de>
+
+ * 1.07-2 :
+ (package adopted)
+ added .desktop file
+ new systemwide data dir /usr/share/yamagi-quake2
+ added documentation and license
diff --git a/yamagi-quake2-rogue.desktop b/yamagi-quake2-rogue.desktop
new file mode 100644
index 000000000000..e63fa3919f93
--- /dev/null
+++ b/yamagi-quake2-rogue.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Quake II - Mission Pack 2 (rogue)
+Comment=Ground Zero (Yamagi Quake II)
+Icon=yamagi-quake2
+Exec=yamagi-quake2-rogue
+Categories=Game;Shooter;
+Terminal=false
+StartupNotify=false
diff --git a/yamagi-quake2-rogue.install b/yamagi-quake2-rogue.install
new file mode 100644
index 000000000000..e0729fc62c08
--- /dev/null
+++ b/yamagi-quake2-rogue.install
@@ -0,0 +1,9 @@
+
+post_install() {
+ echo "You need Quake II - Mission Pack 2 ('Ground Zero') data files to play,"
+ echo "copy them to '~/.yq2/rogue'."
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/yamagi-quake2-rogue.sh b/yamagi-quake2-rogue.sh
new file mode 100644
index 000000000000..24f783994374
--- /dev/null
+++ b/yamagi-quake2-rogue.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec yamagi-quake2 +set game rogue $*