summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2022-07-07 14:04:06 +0200
committerCarsten Teibes2022-07-07 14:04:06 +0200
commitdb6dac5e7e6d9251cf2e95cb8755ea188bf68fbe (patch)
treeda4c9d1659f50aa0b404f088de84bbe78160a31e
parentc0c814c931d4ace93a0b7912434c0b56256e3ce8 (diff)
downloadaur-db6dac5e7e6d9251cf2e95cb8755ea188bf68fbe.tar.gz
[upd] 2.08→2.09
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aacdc345e2cb..b864475786c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = yamagi-quake2-rogue
pkgdesc = Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2
- pkgver = 2.08
+ pkgver = 2.09
pkgrel = 1
- url = http://www.yamagi.org/quake2/
+ url = https://www.yamagi.org/quake2/
install = yamagi-quake2-rogue.install
arch = i686
arch = x86_64
license = GPL
license = custom
- makedepends = cmake
- makedepends = ninja
depends = sh
depends = yamagi-quake2
- source = http://deponie.yamagi.org/quake2/quake2-rogue-2.08.tar.xz
+ source = https://deponie.yamagi.org/quake2/quake2-rogue-2.09.tar.xz
source = yamagi-quake2-rogue.sh
source = yamagi-quake2-rogue.desktop
- sha256sums = 524b7f3b9399376cd22c8dd53403bef3e98e754b16154f2bd91d170b55b55920
+ sha256sums = ab66f3133782d003fcf3c2e3e19e311d9c2c6e59fb7b181c88103d270e8992ad
sha256sums = 7d43bd0ca15a6c82560153deea1df1109d0a448b226e316b6b7b5daae256241a
sha256sums = e7ee884b1e015743659cf668afa521976de64345872acf8e4c1e6932355c2959
diff --git a/PKGBUILD b/PKGBUILD
index 58405008501f..799a78f4de17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,45 +2,40 @@
# Contributors: Frederic Bezies, Ronan Rabouin
pkgname=yamagi-quake2-rogue
-pkgver=2.08
+pkgver=2.09
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2"
-url="http://www.yamagi.org/quake2/"
+url="https://www.yamagi.org/quake2/"
license=('GPL' 'custom')
depends=('sh' 'yamagi-quake2')
-makedepends=('cmake' 'ninja')
install=$pkgname.install
-source=("http://deponie.yamagi.org/quake2/${pkgname#*-}-$pkgver.tar.xz"
+source=("https://deponie.yamagi.org/quake2/${pkgname#*-}-$pkgver.tar.xz"
"$pkgname.sh"
"$pkgname.desktop")
-sha256sums=('524b7f3b9399376cd22c8dd53403bef3e98e754b16154f2bd91d170b55b55920'
+sha256sums=('ab66f3133782d003fcf3c2e3e19e311d9c2c6e59fb7b181c88103d270e8992ad'
'7d43bd0ca15a6c82560153deea1df1109d0a448b226e316b6b7b5daae256241a'
'e7ee884b1e015743659cf668afa521976de64345872acf8e4c1e6932355c2959')
build() {
- rm -rf build
- cmake ${pkgname#*-}-$pkgver -Bbuild \
- -DCMAKE_BUILD_TYPE=Release \
- -GNinja
- cmake --build build
+ make -C ${pkgname#*-}-$pkgver
}
package() {
- # game library
- install -Dm644 build/Release/game.so "$pkgdir"/usr/lib/yamagi-quake2/rogue/game.so
-
cd ${pkgname#*-}-$pkgver
+ # game library
+ install -Dm644 -t "$pkgdir"/usr/lib/yamagi-quake2/rogue release/game.so
+
# game launcher
install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
# doc
- install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+ install -Dm644 -t "$pkgdir"/usr/share/doc/$pkgname README
# desktop entry
- install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/applications ../$pkgname.desktop
# license
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
}