summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2021-07-06 02:15:42 +0200
committerCarsten Teibes2021-07-06 02:15:42 +0200
commita076a4cd1275dd90ef827eb7f5be1c2af90de659 (patch)
treeedd1d23ae810f8c595f9466ca710d1a39b43c177
parentf9421c5833ae26532091b1172df0f04a6a63ed7d (diff)
downloadaur-yamagi-quake2-rogue-git.tar.gz
[upd] back to using the Makefile, small cleanup
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
2 files changed, 13 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78444fe1011a..2cd562abb246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = yamagi-quake2-rogue-git
pkgdesc = Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2 (development version)
- pkgver = 2.05.r0.geaaf6c4
+ pkgver = 2.08.r1.gab882a1
pkgrel = 1
- url = http://www.yamagi.org/quake2/
+ url = https://www.yamagi.org/quake2/
install = yamagi-quake2-rogue.install
arch = i686
arch = x86_64
license = GPL
license = custom
- makedepends = cmake
- makedepends = ninja
depends = sh
depends = yamagi-quake2
provides = yamagi-quake2-rogue
@@ -22,4 +20,3 @@ pkgbase = yamagi-quake2-rogue-git
sha256sums = e7ee884b1e015743659cf668afa521976de64345872acf8e4c1e6932355c2959
pkgname = yamagi-quake2-rogue-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3781b89c9e6f..db8c1382032d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=yamagi-quake2-rogue-git
-pkgver=2.05.r0.geaaf6c4
+pkgver=2.08.r1.gab882a1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2 (development version)"
-url="http://www.yamagi.org/quake2/"
+url="https://www.yamagi.org/quake2/"
license=('GPL' 'custom')
depends=('sh' 'yamagi-quake2')
-makedepends=('cmake' 'ninja')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install=${pkgname%-*}.install
@@ -25,27 +24,25 @@ pkgver() {
}
build() {
- rm -rf build
- cmake ${pkgname%-*} -Bbuild \
- -DCMAKE_BUILD_TYPE=Release \
- -GNinja
- cmake --build build
+ make -C ${pkgname%-*}
}
package() {
- # game library
- install -Dm644 build/Release/game.so "$pkgdir"/usr/lib/yamagi-quake2/rogue/game.so
+ local pkg=${pkgname%-*}
- cd ${pkgname%-*}
+ cd $pkg
+
+ # game library
+ install -Dm644 -t "$pkgdir"/usr/lib/yamagi-quake2/rogue release/game.so
# game launcher
- install -Dm755 ../${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
+ install -Dm755 ../$pkg.sh "$pkgdir"/usr/bin/$pkg
# doc
- install -Dm644 README "$pkgdir"/usr/share/doc/${pkgname%-*}/README
+ install -Dm644 -t "$pkgdir"/usr/share/doc/$pkg README
# desktop entry
- install -Dm644 ../${pkgname%-*}.desktop "$pkgdir"/usr/share/applications/${pkgname%-*}.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/applications ../$pkg.desktop
# license
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE