summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-01-24 03:28:51 +0100
committerCarsten Teibes2014-01-24 03:28:51 +0100
commit03fc093a05fd0a84966154a19370bb9c9b702a1c (patch)
treebda216303ed7267a056af00b776c441ee8b068bc
downloadaur-03fc093a05fd0a84966154a19370bb9c9b702a1c.tar.gz
[add] yamagi-quake2-xatrix 2.00
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
-rw-r--r--yamagi-quake2-xatrix.ChangeLog8
-rw-r--r--yamagi-quake2-xatrix.desktop10
-rw-r--r--yamagi-quake2-xatrix.install9
-rw-r--r--yamagi-quake2-xatrix.sh3
6 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1406df6ff64f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = yamagi-quake2-xatrix
+ pkgdesc = Quake II - Mission Pack 1 ('The Reckoning') for yamagi-quake2
+ pkgver = 2.00
+ pkgrel = 1
+ url = http://www.yamagi.org/quake2/
+ install = yamagi-quake2-xatrix.install
+ changelog = yamagi-quake2-xatrix.ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ depends = sh
+ depends = yamagi-quake2
+ source = http://deponie.yamagi.org/quake2/quake2-xatrix-2.00.tar.xz
+ source = yamagi-quake2-xatrix.sh
+ source = yamagi-quake2-xatrix.desktop
+ sha256sums = 11b8d9eb8ae98e7fa15946d28edb87d5d571c8a51a515d5bc50db13837cb0f10
+ sha256sums = 7c60d4bd78a528f5cf08425cfdcb87dacf574d3912c44439e623e35f37fbc972
+ sha256sums = 8f13e4f6afc9e60fa7d52856397d03a8ed5b87418cea6e0281d083a5573b3647
+
+pkgname = yamagi-quake2-xatrix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..697abbe32865
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: Frederic Bezies <fredbezies@gmail.com>
+# Contributor: Ronan Rabouin <darkbaboon@gmail.com>
+
+_pkgbase=quake2-xatrix
+pkgname=yamagi-$_pkgbase
+pkgver=2.00
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Quake II - Mission Pack 1 ('The Reckoning') for yamagi-quake2"
+url="http://www.yamagi.org/quake2/"
+license=('GPL' 'custom')
+depends=('sh' 'yamagi-quake2')
+install=$pkgname.install
+changelog=$pkgname.ChangeLog
+source=("http://deponie.yamagi.org/quake2/$_pkgbase-$pkgver.tar.xz"
+ "$pkgname.sh" "$pkgname.desktop")
+sha256sums=('11b8d9eb8ae98e7fa15946d28edb87d5d571c8a51a515d5bc50db13837cb0f10'
+ '7c60d4bd78a528f5cf08425cfdcb87dacf574d3912c44439e623e35f37fbc972'
+ '8f13e4f6afc9e60fa7d52856397d03a8ed5b87418cea6e0281d083a5573b3647')
+
+build() {
+ cd $_pkgbase-$pkgver
+
+ make
+}
+
+package() {
+ cd $_pkgbase-$pkgver
+
+ # game launcher
+ install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
+
+ # game library
+ install -Dm644 release/game.so "$pkgdir"/usr/share/yamagi-quake2/xatrix/game.so
+
+ # doc
+ install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+
+ # desktop entry
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ # license
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/yamagi-quake2-xatrix.ChangeLog b/yamagi-quake2-xatrix.ChangeLog
new file mode 100644
index 000000000000..0a8b169d5383
--- /dev/null
+++ b/yamagi-quake2-xatrix.ChangeLog
@@ -0,0 +1,8 @@
+2014-01-24 carstene1ns <url/mail: arch carsten-teibes de>
+
+ * 2.00-1 :
+ (package adopted)
+ new upstream release.
+ added .desktop file
+ new systemwide data dir /usr/share/yamagi-quake2
+ added documentation and license
diff --git a/yamagi-quake2-xatrix.desktop b/yamagi-quake2-xatrix.desktop
new file mode 100644
index 000000000000..a804dad660d4
--- /dev/null
+++ b/yamagi-quake2-xatrix.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Quake II - Mission Pack 1 (xatrix)
+Comment=The Reckoning (Yamagi Quake II)
+Icon=yamagi-quake2
+Exec=yamagi-quake2-xatrix
+Categories=Game;Shooter;
+Terminal=false
+StartupNotify=false
diff --git a/yamagi-quake2-xatrix.install b/yamagi-quake2-xatrix.install
new file mode 100644
index 000000000000..37ed4a318195
--- /dev/null
+++ b/yamagi-quake2-xatrix.install
@@ -0,0 +1,9 @@
+
+post_install() {
+ echo "You need Quake II - Mission Pack 1 ('The Reckoning') data files to play,"
+ echo "copy them to '~/.yq2/xatrix'."
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/yamagi-quake2-xatrix.sh b/yamagi-quake2-xatrix.sh
new file mode 100644
index 000000000000..7a51f48682ef
--- /dev/null
+++ b/yamagi-quake2-xatrix.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec yamagi-quake2 +set game xatrix $*