summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-04-15 23:37:58 +0200
committerCarsten Teibes2015-04-15 23:37:58 +0200
commit549cb08e1721efd9d9825aab00798431143937ce (patch)
treedf1f7ea5e9d6f878aa8783d2425cf0a72a191a75
downloadaur-549cb08e1721efd9d9825aab00798431143937ce.tar.gz
[add] yamagi-quake2-xatrix-git
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--yamagi-quake2-xatrix.desktop9
-rw-r--r--yamagi-quake2-xatrix.install9
-rw-r--r--yamagi-quake2-xatrix.sh3
5 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30f1d38f77a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = yamagi-quake2-xatrix-git
+ pkgdesc = Quake II - Mission Pack 1 ('The Reckoning') for yamagi-quake2 (development version)
+ pkgver = 2.01.r3.g150c521
+ pkgrel = 1
+ url = http://www.yamagi.org/quake2/
+ install = yamagi-quake2-xatrix.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ depends = sh
+ depends = yamagi-quake2
+ provides = yamagi-quake2-xatrix
+ conflicts = yamagi-quake2-xatrix
+ source = yamagi-quake2-xatrix::git+https://github.com/yquake2/xatrix.git
+ source = yamagi-quake2-xatrix.sh
+ source = yamagi-quake2-xatrix.desktop
+ sha256sums = SKIP
+ sha256sums = 7c60d4bd78a528f5cf08425cfdcb87dacf574d3912c44439e623e35f37fbc972
+ sha256sums = e65add2561c7dc4a14061e17a24436f768b69968fbc6fa06022acf9e17d80854
+
+pkgname = yamagi-quake2-xatrix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..075bdeeeafeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=yamagi-quake2-xatrix-git
+pkgver=2.01.r3.g150c521
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Quake II - Mission Pack 1 ('The Reckoning') for yamagi-quake2 (development version)"
+url="http://www.yamagi.org/quake2/"
+license=('GPL' 'custom')
+depends=('sh' 'yamagi-quake2')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+install=${pkgname%-*}.install
+source=(${pkgname%-*}::"git+https://github.com/yquake2/xatrix.git"
+ "${pkgname%-*}.sh"
+ "${pkgname%-*}.desktop")
+sha256sums=('SKIP'
+ '7c60d4bd78a528f5cf08425cfdcb87dacf574d3912c44439e623e35f37fbc972'
+ 'e65add2561c7dc4a14061e17a24436f768b69968fbc6fa06022acf9e17d80854')
+
+pkgver() {
+ cd ${pkgname%-*}
+ git describe --long --tags | sed 's/^XATRIX_//;s/_/./;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ make -C ${pkgname%-*}
+}
+
+package() {
+ cd ${pkgname%-*}
+
+ # game launcher
+ install -Dm755 ../${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
+
+ # game library
+ install -Dm644 release/game.so "$pkgdir"/usr/share/yamagi-quake2/xatrix/game.so
+
+ # doc
+ install -Dm644 README "$pkgdir"/usr/share/doc/${pkgname%-*}/README
+
+ # desktop entry
+ install -Dm644 ../${pkgname%-*}.desktop "$pkgdir"/usr/share/applications/${pkgname%-*}.desktop
+
+ # license
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/yamagi-quake2-xatrix.desktop b/yamagi-quake2-xatrix.desktop
new file mode 100644
index 000000000000..acce32560f5a
--- /dev/null
+++ b/yamagi-quake2-xatrix.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Yamagi Quake II - Mission Pack 1 (xatrix)
+Comment=The Reckoning
+Icon=yamagi-quake2
+Exec=yamagi-quake2-xatrix
+Categories=Game;Shooter;
+Terminal=false
+StartupNotify=false
diff --git a/yamagi-quake2-xatrix.install b/yamagi-quake2-xatrix.install
new file mode 100644
index 000000000000..37ed4a318195
--- /dev/null
+++ b/yamagi-quake2-xatrix.install
@@ -0,0 +1,9 @@
+
+post_install() {
+ echo "You need Quake II - Mission Pack 1 ('The Reckoning') data files to play,"
+ echo "copy them to '~/.yq2/xatrix'."
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/yamagi-quake2-xatrix.sh b/yamagi-quake2-xatrix.sh
new file mode 100644
index 000000000000..7a51f48682ef
--- /dev/null
+++ b/yamagi-quake2-xatrix.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec yamagi-quake2 +set game xatrix $*