summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Blumenstingl2019-07-03 16:28:44 +0200
committerMartin Blumenstingl2019-07-03 16:28:44 +0200
commita8aa8367a06a8afedfdb6c3e437154df285d6cb0 (patch)
treec68522284fc693ecab429f5bf88859765a7387a9
downloadaur-a8aa8367a06a8afedfdb6c3e437154df285d6cb0.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43f237612fb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yaml-bindings-git
+ pkgdesc = Tooling for devicetree validation using YAML and jsonschema
+ pkgver = r344.dec452c
+ pkgrel = 1
+ url = https://github.com/robherring/yaml-bindings
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-ruamel-yaml
+ depends = python-jsonschema
+ depends = python-rfc3987
+ source = yaml-bindings::git+https://github.com/robherring/yaml-bindings
+ sha1sums = SKIP
+
+pkgname = yaml-bindings-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e278338e34c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
+
+pkgname=yaml-bindings-git
+pkgver=r344.dec452c
+pkgrel=1
+pkgdesc='Tooling for devicetree validation using YAML and jsonschema'
+arch=(any)
+url="https://github.com/robherring/yaml-bindings"
+license=('BSD')
+depends=('python' 'python-ruamel-yaml' 'python-jsonschema' 'python-rfc3987')
+makedepends=('python-setuptools')
+source=('yaml-bindings::git+https://github.com/robherring/yaml-bindings')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}