summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2021-03-26 17:20:47 +0800
committerAllen Zhong2021-03-26 17:20:47 +0800
commite98f0c62732155b5e2ddd766fc6aed280f243355 (patch)
tree23ca4ee09bbf1a2568236d04dc97390e0c9e2654
parentca971f23929913222fbcda5e6a09ffc899560e32 (diff)
downloadaur-e98f0c62732155b5e2ddd766fc6aed280f243355.tar.gz
update to git master
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef404898943e..a454c2349905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = yaml2json
pkgdesc = Transform yaml string to json string without the type infomation.
- pkgver = 1.3
+ pkgver = 1.3.r4.g82e774e
pkgrel = 1
url = https://github.com/bronze1man/yaml2json
arch = x86_64
license = MIT
- makedepends = go-pie
- source = https://github.com/bronze1man/yaml2json/archive/v1.3.tar.gz
- sha256sums = fd0954936fef9f4848ef37debb25b26479495df0a8d46582e1e307cb29cdafc1
+ makedepends = go
+ makedepends = git
+ source = yaml2json::git+https://github.com/bronze1man/yaml2json.git
+ sha256sums = SKIP
pkgname = yaml2json
diff --git a/.gitignore b/.gitignore
index 717a3fa96186..fc3eda3bb0e5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
+yaml2json/
*.log
*.gz
diff --git a/PKGBUILD b/PKGBUILD
index 12d8550562fe..c1a7e2573c0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
# Maintainer: Allen Zhong <moeallenz@gmail.com>
pkgname=yaml2json
-pkgver=1.3
+pkgver=1.3.r4.g82e774e
pkgrel=1
pkgdesc="Transform yaml string to json string without the type infomation."
url="https://github.com/bronze1man/yaml2json"
license=('MIT')
arch=('x86_64')
-makedepends=('go-pie' )
-sha256sums=('fd0954936fef9f4848ef37debb25b26479495df0a8d46582e1e307cb29cdafc1')
+makedepends=('go' 'git')
+sha256sums=('SKIP')
source=(
- https://github.com/bronze1man/yaml2json/archive/v${pkgver}.tar.gz
+ $pkgname::git+https://github.com/bronze1man/yaml2json.git
)
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed -r "s/([^-]*-g)/r\1/;s/-/./g;s/^v//"
+}
+
build() {
mkdir -p ${srcdir}/gobuild
export GOPATH="${srcdir}/gobuild"
+ export GO111MODULE=off
- mv "${srcdir}/${pkgname}-${pkgver}/vendor" "$GOPATH/src"
+ mv "${srcdir}/${pkgname}/vendor" "$GOPATH/src"
mkdir -p "$GOPATH/src/github.com/bronze1man"
- cp -r "${srcdir}/${pkgname}-${pkgver}" $GOPATH/src/github.com/bronze1man/yaml2json
+ cp -r "${srcdir}/${pkgname}" $GOPATH/src/github.com/bronze1man/yaml2json
cd "$GOPATH/src/github.com/bronze1man/yaml2json"
#go run github.com/bronze1man/yaml2json/y2jBuilder