summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus2022-11-09 08:41:24 +0100
committerMatheus2022-11-09 08:41:24 +0100
commit312e164430bee1307ebb129730672dd7c17f20c0 (patch)
treefa6bef5bc5cfa6529487024c824717a2d933b5b1
parent02a47ad6eaa5b8fec30fc06d75d3f771dbdca9ac (diff)
downloadaur-312e164430bee1307ebb129730672dd7c17f20c0.tar.gz
Update.
-rwxr-xr-x.SRCINFO4
-rwxr-xr-x.gitignore6
-rwxr-xr-xPKGBUILD12
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92f87c784756..666b9e7fe37d 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,8 +5,8 @@ pkgbase = yamlfix
url = https://github.com/lyz-code/yamlfix
arch = any
license = GPL3
- makedepends = python-pdm
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
depends = python
depends = python-click
depends = python-ruyaml
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..08d2e8f9b2a6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!*.install
+!*.sh
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 0d007113ee9c..dbf57820b44a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
#!/usr/bin/env bash
# shellcheck disable=SC2034
# shellcheck disable=SC2154
-# Maintainer: Matheus Gabriel Werny de Lima <matheusgwdl@protonmail.com>
+# The PKGBUILD for yamlfix.
+# Maintainer: Matheus <matheusgwdl@protonmail.com>
+# Contributor: Matheus <matheusgwdl@protonmail.com>
pkgname="yamlfix"
pkgver="1.1.0"
@@ -11,14 +13,14 @@ arch=("any")
url="https://github.com/lyz-code/${pkgname}"
license=("GPL3")
depends=("python" "python-click" "python-ruyaml")
-makedepends=("python-pdm" "python-pip")
+makedepends=("python-build" "python-installer")
source=("${pkgname}-v${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
sha512sums=("bbd71dae1baf088382e0dd792ea8c92b04b8b5ef7ff0c3fb3f03d85a51765e8d1fab455d76512e4b540b11c7f696e21859c2007f2654ea142cbfff666e127bdb")
build()
{
cd "${srcdir}"/"${pkgname}"-"${pkgver}"/ || exit 1
- pdm build
+ python -m build -n -w
}
package()
@@ -28,9 +30,11 @@ package()
# Install the software.
cd "${srcdir}"/"${pkgname}"-"${pkgver}"/ || exit 1
- pip install --no-deps --root "${pkgdir}" "${srcdir}"/"${pkgname}"-"${pkgver}"/dist/"${pkgname}"-"${pkgver}"-py3-none-any.whl
+ python -m installer -d "${pkgdir}" "${srcdir}"/"${pkgname}"-"${pkgver}"/dist/*.whl # TODO
# Install the documentation.
install -Dm644 "${srcdir}"/"${pkgname}"-"${pkgver}"/README.md "${pkgdir}"/usr/share/doc/"${pkgname}"/
cp -r "${srcdir}"/"${pkgname}"-"${pkgver}"/docs/* "${pkgdir}"/usr/share/doc/"${pkgname}"/
+ find "${pkgdir}"/usr/share/doc/"${pkgname}"/ -type d -exec chmod 755 {} +
+ find "${pkgdir}"/usr/share/doc/"${pkgname}"/ -type f -exec chmod 644 {} +
}