summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus Gabriel Werny de Lima2022-09-26 09:13:49 +0200
committerMatheus Gabriel Werny de Lima2022-09-26 09:13:49 +0200
commit46feaec5c26c92ec3f65ec13805dda808a80b3f4 (patch)
tree5b8dbdff7c40e2d55715c20606754824664b7a81
downloadaur-46feaec5c26c92ec3f65ec13805dda808a80b3f4.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92f87c784756
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = yamlfix
+ pkgdesc = A simple, opinionated yaml formatter that keeps your comments!
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/lyz-code/yamlfix
+ arch = any
+ license = GPL3
+ makedepends = python-pdm
+ makedepends = python-pip
+ depends = python
+ depends = python-click
+ depends = python-ruyaml
+ source = yamlfix-v1.1.0.tar.gz::https://github.com/lyz-code/yamlfix/archive/refs/tags/1.1.0.tar.gz
+ sha512sums = bbd71dae1baf088382e0dd792ea8c92b04b8b5ef7ff0c3fb3f03d85a51765e8d1fab455d76512e4b540b11c7f696e21859c2007f2654ea142cbfff666e127bdb
+
+pkgname = yamlfix
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..5c8467dbb160
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+#!/bin/bash
+# shellcheck disable=SC2034
+# shellcheck disable=SC2154
+# Maintainer: Matheus Gabriel Werny de Lima <matheusgwdl@protonmail.com>
+
+pkgname="yamlfix"
+pkgver="1.1.0"
+pkgrel="1"
+pkgdesc="A simple, opinionated yaml formatter that keeps your comments!"
+arch=("any")
+url="https://github.com/lyz-code/${pkgname}"
+license=("GPL3")
+depends=("python" "python-click" "python-ruyaml")
+makedepends=("python-pdm" "python-pip")
+source=("${pkgname}-v${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha512sums=("bbd71dae1baf088382e0dd792ea8c92b04b8b5ef7ff0c3fb3f03d85a51765e8d1fab455d76512e4b540b11c7f696e21859c2007f2654ea142cbfff666e127bdb")
+
+build()
+{
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"/ || exit 1
+ pdm build
+}
+
+package()
+{
+ # Assure that the directories exist.
+ mkdir -p "${pkgdir}"/usr/share/doc/"${pkgname}"/
+
+ # Install the software.
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"/ || exit 1
+ pip install --no-deps --root "${pkgdir}" "${srcdir}"/"${pkgname}"-"${pkgver}"/dist/"${pkgname}"-"${pkgver}"-py3-none-any.whl
+
+ # Install the documentation.
+ install -Dm644 "${srcdir}"/"${pkgname}"-"${pkgver}"/README.md "${pkgdir}"/usr/share/doc/"${pkgname}"/
+ cp -r "${srcdir}"/"${pkgname}"-"${pkgver}"/docs/* "${pkgdir}"/usr/share/doc/"${pkgname}"/
+}