summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus2022-11-09 08:47:13 +0100
committerMatheus2022-11-09 08:47:13 +0100
commit9e0c2f7b9af361542429f3a8091981da9e5ace77 (patch)
tree59e98add1b557111bdb9848319cba49c3ada0e18
parent312e164430bee1307ebb129730672dd7c17f20c0 (diff)
downloadaur-9e0c2f7b9af361542429f3a8091981da9e5ace77.tar.gz
Revision.
-rwxr-xr-x.SRCINFO1
-rwxr-xr-xPKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 666b9e7fe37d..785f12c56ef8 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = yamlfix
license = GPL3
makedepends = python-build
makedepends = python-installer
+ makedepends = python-pdm
depends = python
depends = python-click
depends = python-ruyaml
diff --git a/PKGBUILD b/PKGBUILD
index dbf57820b44a..942d088a32a9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ arch=("any")
url="https://github.com/lyz-code/${pkgname}"
license=("GPL3")
depends=("python" "python-click" "python-ruyaml")
-makedepends=("python-build" "python-installer")
+makedepends=("python-build" "python-installer" "python-pdm")
source=("${pkgname}-v${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
sha512sums=("bbd71dae1baf088382e0dd792ea8c92b04b8b5ef7ff0c3fb3f03d85a51765e8d1fab455d76512e4b540b11c7f696e21859c2007f2654ea142cbfff666e127bdb")
@@ -30,7 +30,7 @@ package()
# Install the software.
cd "${srcdir}"/"${pkgname}"-"${pkgver}"/ || exit 1
- python -m installer -d "${pkgdir}" "${srcdir}"/"${pkgname}"-"${pkgver}"/dist/*.whl # TODO
+ python -m installer -d "${pkgdir}" "${srcdir}"/"${pkgname}"-"${pkgver}"/dist/*.whl
# Install the documentation.
install -Dm644 "${srcdir}"/"${pkgname}"-"${pkgver}"/README.md "${pkgdir}"/usr/share/doc/"${pkgname}"/