summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirMozor2022-07-08 20:09:58 +0600
committerKirMozor2022-07-08 20:09:58 +0600
commit22263367badd4839ce78f12e08db560eb6d40160 (patch)
tree287c7d573509474b4b61aacf0dc5d2de6596a5d9
parentb7023243af586077260dfc083b2710c7555adf5c (diff)
downloadaur-22263367badd4839ce78f12e08db560eb6d40160.tar.gz
Corrections by Ventureo
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD37
-rw-r--r--post.install3
3 files changed, 25 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1dbd840ac2b..5ef5da0a60d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = yamux
- pkgdesc = This is a yandex music client for Linux written in C# with YandexMusicAPI
+ pkgdesc = Yandex Music Client
pkgver = v54
- pkgrel = 1
- epoch = 1
+ pkgrel = 2
url = https://gitlab.com/KirMozor/Yamux
- install = post.install
arch = x86_64
license = GPL3
makedepends = dotnet-sdk>=6.0.0
depends = libbass
depends = dotnet-runtime>=6.0.0
- source = https://gitlab.com/KirMozor/Yamux/-/archive/Yamux-v54/Yamux-Yamux-v54.tar.gz
+ depends = gtk3
+ source = git+https://gitlab.com/KirMozor/Yamux.git#tag=Yamux-v54
md5sums = SKIP
pkgname = yamux
diff --git a/PKGBUILD b/PKGBUILD
index 5203deba6657..4fcdde396b6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,36 @@
# Maintainer: KirMozor <kirmozor96@gmail.com>
# Contributor: Archie <archie-woc@ya.ru>
+# Contributor: Vasiliy Stelmachenok <ventureo@yandex.ru>
pkgname=yamux
pkgver=v54
-pkgrel=1
-epoch=1
-pkgdesc="This is a yandex music client for Linux written in C# with YandexMusicAPI"
-arch=("x86_64")
+pkgrel=2
+pkgdesc="Yandex Music Client"
+arch=('x86_64')
url="https://gitlab.com/KirMozor/Yamux"
license=('GPL3')
-depends=("libbass" "dotnet-runtime>=6.0.0")
+depends=('libbass' 'dotnet-runtime>=6.0.0' 'gtk3')
makedepends=("dotnet-sdk>=6.0.0")
-source=("https://gitlab.com/KirMozor/Yamux/-/archive/Yamux-v54/Yamux-Yamux-v54.tar.gz")
+source=("git+https://gitlab.com/KirMozor/Yamux.git#tag=Yamux-$pkgver")
md5sums=(SKIP)
-install=post.install
build() {
- cd Yamux-Yamux-$pkgver
- dotnet build --configuration Release
+ cd Yamux
+ dotnet build -c Release
}
package() {
- cd Yamux-Yamux-$pkgver
+ cd "${srcdir}/Yamux"
+
+ # Copy theme
cp -r Svg ./bin/Release/net6.0/linux-x64
- mkdir -p $pkgdir/opt/
- cp -r ./bin/Release/net6.0/linux-x64/. $pkgdir/opt/Yamux
- # mkdir -p $pkgdir/usr/local/bin/Yamux
- # ln -sf $pkgdir/usr/local/bin/Yamux/Yamux $pkgdir/usr/bin/Yamux
- # cp ./bin/Release/net6.0/linux-x64/Yamux $pkgdir/usr/bin
- # chmod +x "$pkgdir/usr/bin/Yamux"
+
+ # Copy binaries
+ mkdir -p "$pkgdir/opt"
+ cp -r ./bin/Release/net6.0/linux-x64/. "$pkgdir/opt/Yamux"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -sf /opt/Yamux/Yamux "$pkgdir"/usr/bin/yamux
+
+ # License
+ cp -r LICENSE "$pkgdir/opt/Yamux"
}
diff --git a/post.install b/post.install
deleted file mode 100644
index 04cf8ddab032..000000000000
--- a/post.install
+++ /dev/null
@@ -1,3 +0,0 @@
-post_install() {
- ln -sf /opt/Yamux/Yamux /usr/bin/Yamux
-}