summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirMozor2022-07-08 16:39:04 +0600
committerKirMozor2022-07-08 16:39:04 +0600
commitb7023243af586077260dfc083b2710c7555adf5c (patch)
treeeec4b1af6f86b1f788a8c1bcb983af61ebe493f9
downloadaur-b7023243af586077260dfc083b2710c7555adf5c.tar.gz
Publishing Yamux's first AUR package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--post.install3
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1dbd840ac2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = yamux
+ pkgdesc = This is a yandex music client for Linux written in C# with YandexMusicAPI
+ pkgver = v54
+ pkgrel = 1
+ epoch = 1
+ url = https://gitlab.com/KirMozor/Yamux
+ install = post.install
+ arch = x86_64
+ license = GPL3
+ makedepends = dotnet-sdk>=6.0.0
+ depends = libbass
+ depends = dotnet-runtime>=6.0.0
+ source = https://gitlab.com/KirMozor/Yamux/-/archive/Yamux-v54/Yamux-Yamux-v54.tar.gz
+ md5sums = SKIP
+
+pkgname = yamux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5203deba6657
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: KirMozor <kirmozor96@gmail.com>
+# Contributor: Archie <archie-woc@ya.ru>
+pkgname=yamux
+pkgver=v54
+pkgrel=1
+epoch=1
+pkgdesc="This is a yandex music client for Linux written in C# with YandexMusicAPI"
+arch=("x86_64")
+url="https://gitlab.com/KirMozor/Yamux"
+license=('GPL3')
+depends=("libbass" "dotnet-runtime>=6.0.0")
+makedepends=("dotnet-sdk>=6.0.0")
+source=("https://gitlab.com/KirMozor/Yamux/-/archive/Yamux-v54/Yamux-Yamux-v54.tar.gz")
+md5sums=(SKIP)
+install=post.install
+
+build() {
+ cd Yamux-Yamux-$pkgver
+ dotnet build --configuration Release
+}
+
+package() {
+ cd Yamux-Yamux-$pkgver
+ cp -r Svg ./bin/Release/net6.0/linux-x64
+ mkdir -p $pkgdir/opt/
+ cp -r ./bin/Release/net6.0/linux-x64/. $pkgdir/opt/Yamux
+ # mkdir -p $pkgdir/usr/local/bin/Yamux
+ # ln -sf $pkgdir/usr/local/bin/Yamux/Yamux $pkgdir/usr/bin/Yamux
+ # cp ./bin/Release/net6.0/linux-x64/Yamux $pkgdir/usr/bin
+ # chmod +x "$pkgdir/usr/bin/Yamux"
+}
diff --git a/post.install b/post.install
new file mode 100644
index 000000000000..04cf8ddab032
--- /dev/null
+++ b/post.install
@@ -0,0 +1,3 @@
+post_install() {
+ ln -sf /opt/Yamux/Yamux /usr/bin/Yamux
+}