summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShengyu Zhang2017-11-20 09:29:10 +0800
committerShengyu Zhang2017-11-20 09:29:10 +0800
commit9951ab5e81f5bb0eb9d841aadab391cf7e510a2b (patch)
treedb149551ab73e9ac9a45813f9d8a20ec74fb9610
downloadaur-9951ab5e81f5bb0eb9d841aadab391cf7e510a2b.tar.gz
addpkg: yanshi-git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e2beec13798
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Nov 20 01:28:56 UTC 2017
+pkgbase = yanshi-git
+ pkgdesc = A regular language recognizer generater like Ragel, enhanced with features to approximate context-free grammars and substring grammars
+ pkgver = 0.57.9d86e63
+ pkgrel = 1
+ url = https://github.com/chaitin/yanshi
+ arch = x86_64
+ license = Custom
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ depends = glibc
+ depends = icu
+ provides = yanshi
+ source = git+https://github.com/chaitin/yanshi.git
+ sha256sums = SKIP
+
+pkgname = yanshi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b53408598033
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Shengyu Zhang <la@archlinuxcn.org>
+
+pkgname=yanshi-git
+_pkgname=yanshi
+pkgver=0.57.9d86e63
+pkgrel=1
+pkgdesc='A regular language recognizer generater like Ragel, enhanced with features to approximate context-free grammars and substring grammars'
+arch=('x86_64')
+license=('Custom')
+url="https://github.com/chaitin/yanshi"
+makedepends=('git' 'make' 'gcc')
+depends=('glibc' 'icu')
+provides=('yanshi')
+source=("git+https://github.com/chaitin/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+check() {
+ cd ${_pkgname}
+ # make unittest
+}
+
+build() {
+ cd ${_pkgname}
+ make build=release
+}
+
+package() {
+ cd ${_pkgname}
+ install -Dm755 release/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+}