summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-23 15:17:59 -0400
committerKyle Keen2015-06-23 15:17:59 -0400
commitf981aa4c5a26a4585059e8d98b24c99d9e7e5ea8 (patch)
tree83556f1e3fc49387fe4576c0ac8c9db661f777e8
downloadaur-f981aa4c5a26a4585059e8d98b24c99d9e7e5ea8.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
-rw-r--r--friend-function.patch37
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a286bacd2e2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = yap
+ pkgdesc = A high-performance Prolog compiler
+ pkgver = 6.2.2
+ pkgrel = 5
+ url = http://www.dcc.fc.up.pt/~vsc/Yap/
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ depends = gmp
+ depends = unixodbc
+ depends = libmariadbclient
+ source = http://www.dcc.fc.up.pt/~vsc/Yap/yap-6.2.2.tar.gz
+ source = friend-function.patch
+ md5sums = 95eaa54978e4811ff6e504e7dca9e835
+ md5sums = 5b5884a62e8cd9482408565576b872f8
+
+pkgname = yap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d79b91473c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# $Id$
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Leonidas <marek@xivilization.net>
+
+pkgname=yap
+pkgver=6.2.2
+pkgrel=5
+pkgdesc='A high-performance Prolog compiler'
+url='http://www.dcc.fc.up.pt/~vsc/Yap/'
+license=('PerlArtistic')
+arch=('i686' 'x86_64')
+depends=('gmp' 'unixodbc' 'libmariadbclient')
+#makedepends=('texi2html' 'texinfo' 'jdk7-openjdk' 'texlive-plainextra')
+#optdepends=('java-runtime-headless: Java Interface Library JPL')
+source=("http://www.dcc.fc.up.pt/~vsc/Yap/${pkgname}-${pkgver}.tar.gz"
+ "friend-function.patch")
+md5sums=('95eaa54978e4811ff6e504e7dca9e835'
+ '5b5884a62e8cd9482408565576b872f8')
+
+# issues building java bindings and info pages?
+# I leave those up to you to fix, dear reader
+
+# gcc 5 patch
+# http://pkgs.fedoraproject.org/cgit/yap.git/plain/yap-6.2.2-Friend-function-template-defined-in-a-class-cannot-b.patch
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ patch -p1 -i ../friend-function.patch
+
+ ./configure \
+ --prefix=/usr \
+ --enable-threads \
+ --enable-dynamic-loading \
+ --enable-max-performance \
+ --enable-max-memory
+ # --with-java="${JAVA_HOME}"
+ make
+
+ #make html
+ #make pdf
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ #make DESTDIR="${pkgdir}" install_docs
+}
diff --git a/friend-function.patch b/friend-function.patch
new file mode 100644
index 000000000000..4261ee1120aa
--- /dev/null
+++ b/friend-function.patch
@@ -0,0 +1,37 @@
+diff --git a/packages/swi-minisat2/C/Solver.C b/packages/swi-minisat2/C/Solver.C
+index 2de3e6d..1bcdbff 100644
+--- a/packages/swi-minisat2/C/Solver.C
++++ b/packages/swi-minisat2/C/Solver.C
+@@ -120,7 +120,7 @@ bool Solver::addClause(vec<Lit>& ps)
+ uncheckedEnqueue(ps[0]);
+ return ok = (propagate() == NULL);
+ }else{
+- Clause* c = Clause_new(ps, false);
++ Clause* c = Clause::Clause_new(ps, false);
+ clauses.push(c);
+ attachClause(*c);
+ }
+@@ -599,7 +599,7 @@ lbool Solver::search(int nof_conflicts, int nof_learnts)
+ if (learnt_clause.size() == 1){
+ uncheckedEnqueue(learnt_clause[0]);
+ }else{
+- Clause* c = Clause_new(learnt_clause, true);
++ Clause* c = Clause::Clause_new(learnt_clause, true);
+ learnts.push(c);
+ attachClause(*c);
+ claBumpActivity(*c);
+diff --git a/packages/swi-minisat2/C/SolverTypes.h b/packages/swi-minisat2/C/SolverTypes.h
+index 47e3023..919b60b 100644
+--- a/packages/swi-minisat2/C/SolverTypes.h
++++ b/packages/swi-minisat2/C/SolverTypes.h
+@@ -119,7 +119,7 @@ public:
+
+ // -- use this function instead:
+ template<class V>
+- friend Clause* Clause_new(const V& ps, bool learnt = false) {
++ static Clause* Clause_new(const V& ps, bool learnt = false) {
+ assert(sizeof(Lit) == sizeof(uint32_t));
+ assert(sizeof(float) == sizeof(uint32_t));
+ void* mem = malloc(sizeof(Clause) + sizeof(uint32_t)*(ps.size()));
+--
+1.9.3