summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2015-11-25 10:31:49 +0100
committerSebastian Wolf2015-11-25 10:31:49 +0100
commit3e2ae712aea4b590d532f841e0a9dcffe9237a1b (patch)
tree04f796a26143f1801b6b071c4ca2789363c101d1
parent25ca768ed969da54d2861909c608844ebb544eb6 (diff)
downloadaur-3e2ae712aea4b590d532f841e0a9dcffe9237a1b.tar.gz
Update to v0.58.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 100e5f20c0ba..9104d6b5a57e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = yape
- pkgdesc = Yet another Commodore plus/4 emulator (SDL port)
- pkgver = 0.36.2
+ pkgdesc = A decent multiplatform Commodore plus/4 and 64 emulator written in C++ using the SDL 2.0 media API
+ pkgver = 0.58.2
pkgrel = 1
- url = http://yape.plus4.net
+ url = http://yapesdl.codeplex.com
arch = i686
arch = x86_64
license = GPL
- depends = sdl
- source = http://yape.homeserver.hu/download/yapeSDL-0.36.2.tar.gz
- md5sums = 7a44d45106261d464c78ed8319fe3bd9
+ depends = sdl2
+ source = yapesdl::git+https://git01.codeplex.com/yapesdl
+ md5sums = SKIP
pkgname = yape
diff --git a/PKGBUILD b/PKGBUILD
index b4469cc0de9c..01ccef83fbaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Contributor: Sebastian Wolf <fatmike303 at googlemail dot com>
pkgname=yape
-pkgver=0.36.2
+pkgver=0.58.2
pkgrel=1
-pkgdesc='Yet another Commodore plus/4 emulator (SDL port)'
+_projectname=yapesdl
+_git_hash=f34a47a03051263df0f27a2b19350f2b0848d85c
+pkgdesc='A decent multiplatform Commodore plus/4 and 64 emulator written in C++ using the SDL 2.0 media API'
arch=('i686' 'x86_64')
-url='http://yape.plus4.net'
+url='http://yapesdl.codeplex.com'
license='GPL'
-depends=('sdl')
-source=(http://yape.homeserver.hu/download/yapeSDL-$pkgver.tar.gz)
-md5sums=('7a44d45106261d464c78ed8319fe3bd9')
+depends=('sdl2')
+source=(${_projectname}::git+https://git01.codeplex.com/${_projectname})
+md5sums=(SKIP)
build() {
+ cd ${srcdir}/${_projectname}
+ git reset --hard ${_git_hash}
make
}
package() {
- install -Dm755 $srcdir/$pkgname $pkgdir/usr/bin/$pkgname
+ install -Dm755 ${srcdir}/${_projectname}/${_projectname} ${pkgdir}/usr/bin/${pkgname}
}