summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-09-13 01:37:38 +0200
committeranthraxx2015-09-13 01:37:38 +0200
commit42147019f233a43d6618b79e6cdadc0348d2208e (patch)
treeb424c993fefa64261b15b6935bc59c6d31056a01
downloadaur-42147019f233a43d6618b79e6cdadc0348d2208e.tar.gz
addpkg: yara-git 3.4.0-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD54
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca16c6029663
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = yara-git
+ pkgdesc = Tool aimed at helping malware researchers to identify and classify malware samples
+ pkgver = 3.4.0
+ pkgrel = 1
+ url = https://plusvic.github.io/yara/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = yara-git::git+https://github.com/plusvic/yara-git
+ sha512sums = SKIP
+
+pkgname = yara-git
+
+pkgname = python-yara-git
+
+pkgname = python2-yara-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c89b9e8b032
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: bitwave <aur [aT] oomlu [d0T] de>
+# Contributor: fnord0 <fnord0 AT riseup DOT net>
+
+pkgbase=yara-git
+pkgname=('yara-git' 'python-yara-git' 'python2-yara-git')
+pkgver=3.4.0
+pkgrel=1
+pkgdesc="Tool aimed at helping malware researchers to identify and classify malware samples"
+url="https://plusvic.github.io/yara/"
+arch=('i686' 'x86_64')
+license=('Apache')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=(${pkgbase}::git+https://github.com/plusvic/${pkgbase})
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2|cut -d- -f1)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgbase}
+ autoreconf --force --install
+ ./configure --prefix=/usr --with-crypto
+ make
+}
+
+package_yara() {
+ depends=('openssl')
+ provides=('yara')
+ conflicts=('yara')
+ cd ${pkgbase}
+ make DESTDIR="${pkgdir}" install
+}
+
+package_python-yara() {
+ depends=('python' 'yara' 'openssl')
+ provides=('python-yara')
+ conflicts=('python-yara')
+ cd ${pkgbase}/${pkgbase}-python
+ python setup.py install --root="${pkgdir}" -O1
+}
+
+package_python2-yara() {
+ depends=('python2' 'yara' 'openssl')
+ provides=('python2-yara')
+ conflicts=('python2-yara')
+ cd ${pkgbase}-${pkgver}/${pkgbase}-python
+ python2 setup.py install --root="${pkgdir}" -O1
+}
+
+# vim: ts=2 sw=2 et: