summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-20 17:44:13 +0800
committerzxp198210052023-11-20 17:44:13 +0800
commit64dc4ce9076780ff7ecd2bb9000c72888ef08d6c (patch)
treec525af74d240e8dac35276438085872370f4aff3
parentd46e0bcb387caab172789c2006691d5067630c60 (diff)
downloadaur-64dc4ce9076780ff7ecd2bb9000c72888ef08d6c.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
-rw-r--r--yarle-evernote-to-md.sh5
3 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f93b326a9ef..b63a51b2fba1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = yarle-evernote-to-md-bin
pkgdesc = Yarle - The ultimate converter of Evernote notes to Markdown
pkgver = 5.8.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/akosbalasko/yarle
arch = x86_64
license = MIT
- depends = bash
depends = electron22
depends = hicolor-icon-theme
provides = yarle-evernote-to-md=5.8.2
@@ -15,6 +14,6 @@ pkgbase = yarle-evernote-to-md-bin
source = yarle-evernote-to-md.sh
sha256sums = b327f774d768cbdbe019c35b5eee3fb1c32a05cba9b17a3ee29aa18154004cc0
sha256sums = 16691c563f896a0d485a742fbd5a389fc7c798ff606c75cb3f753bb7297a9bdb
- sha256sums = 9ac3dafec6213748736616c9de35164d06693509a5a52fc9e76eb617923b1a28
+ sha256sums = 17532f4a93142427e0f4ef0da49de0a3758a342829773d7c83aadcd6c4753a36
pkgname = yarle-evernote-to-md-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9843405eb78b..6cc56ad61768 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,32 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=yarle-evernote-to-md-bin
pkgver=5.8.2
-pkgrel=1
+pkgrel=2
pkgdesc="Yarle - The ultimate converter of Evernote notes to Markdown"
arch=(x86_64)
url="https://github.com/akosbalasko/yarle"
license=('MIT')
-depends=('bash' 'electron22' 'hicolor-icon-theme')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_linux_amd64.deb"
+depends=(
+ 'electron22'
+ 'hicolor-icon-theme'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_linux_amd64.deb"
"LICENSE::https://raw.githubusercontent.com/akosbalasko/yarle/v${pkgver}/LICENSE"
- "${pkgname%-bin}.sh")
+ "${pkgname%-bin}.sh"
+)
sha256sums=('b327f774d768cbdbe019c35b5eee3fb1c32a05cba9b17a3ee29aa18154004cc0'
'16691c563f896a0d485a742fbd5a389fc7c798ff606c75cb3f753bb7297a9bdb'
- '9ac3dafec6213748736616c9de35164d06693509a5a52fc9e76eb617923b1a28')
+ '17532f4a93142427e0f4ef0da49de0a3758a342829773d7c83aadcd6c4753a36')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${pkgname%-bin}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/${pkgname%-bin}/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
+ install -Dm644 "${srcdir}/opt/${pkgname%-bin}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 64x64 192x192 512x512;do
install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
diff --git a/yarle-evernote-to-md.sh b/yarle-evernote-to-md.sh
index 18521e0057e5..ff7069ed44b6 100644
--- a/yarle-evernote-to-md.sh
+++ b/yarle-evernote-to-md.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron22
-_ASAR="/opt/yarle-evernote-to-md/resources/app.asar"
+APPDIR="/usr/lib/yarle-evernote-to-md"
+export PATH="${APPDIR}:${PATH}"
+#export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else