summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Koppe2016-10-12 19:22:11 +0200
committerJan Koppe2016-10-12 19:22:11 +0200
commit43bd40609d591e2801f112e91a77b9fa53386a02 (patch)
tree9654a2b982f4ee79f39dcd7a32d1235696ebd68c
parentd48ace37535233c874888206365a89d282c44643 (diff)
downloadaur-43bd40609d591e2801f112e91a77b9fa53386a02.tar.gz
install without npm
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD28
3 files changed, 18 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fe053453d98..6b7768c76628 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = yarn
pkgdesc = Fast, reliable, and secure dependency management.
- pkgver = 0.15.1
- pkgrel = 3
+ pkgver = 0.15.0
+ pkgrel = 1
url = http://yarnpkg.com
arch = any
license = BSD
- depends = npm
- source = LICENSE
- sha256sums = 3992e4db1e3af655b0413667c9e7089757154d46a36a94659f35fc090fdcf15a
+ depends = nodejs
+ source = https://github.com/yarnpkg/yarn/releases/download/v0.15.0/yarn-v0.15.0.tar.gz
+ sha256sums = 93a8083bd4989d3f7c05fcf57dfe232e00a35a09e48354b9316d2bc43f74b51b
pkgname = yarn
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 4ce2863a248a..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,26 +0,0 @@
-BSD License
-
-For Yarn software
-
-Copyright (c) 2016-present, Yarn Contributors. All rights reserved.
-
-Redistribution and use in source and binary forms, with or without modification,
-are permitted provided that the following conditions are met:
-
- * Redistributions of source code must retain the above copyright notice, this
- list of conditions and the following disclaimer.
-
- * Redistributions in binary form must reproduce the above copyright notice,
- this list of conditions and the following disclaimer in the documentation
- and/or other materials provided with the distribution.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR
-ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
-ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 99252d6f21ab..ce65ea15ba77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
# Maintainer: Jan Koppe <post@jankoppe.de>
-_npmname=yarn
-_npmver=0.15.1
pkgname=yarn
-pkgver=0.15.1
-pkgrel=3
+pkgver=0.15.0
+pkgrel=1
pkgdesc='Fast, reliable, and secure dependency management.'
arch=(any)
url='http://yarnpkg.com'
license=('BSD')
-depends=('npm')
-source=('LICENSE')
-sha256sums=('3992e4db1e3af655b0413667c9e7089757154d46a36a94659f35fc090fdcf15a')
+depends=('nodejs')
+source=("https://github.com/yarnpkg/yarn/releases/download/v$pkgver/yarn-v$pkgver.tar.gz")
+sha256sums=('93a8083bd4989d3f7c05fcf57dfe232e00a35a09e48354b9316d2bc43f74b51b')
-package() {
- mkdir -p "$pkgdir/usr/share/licenses/yarn"
- cp "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/yarn/LICENSE"
- cd "$srcdir"
- local _npmdir="$pkgdir/usr/lib/node_modules/"
- mkdir -p "$_npmdir"
- cd "$_npmdir"
- npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+package() {
+ install -dm755 "$pkgdir"/usr/lib/node_modules/yarn
+ cp -R "$srcdir"/dist/* "$pkgdir"/usr/lib/node_modules/yarn
+
+ install -dm755 "$pkgdir"/usr/bin
+ ln -s /usr/lib/node_modules/yarn/bin/yarn.js "$pkgdir"/usr/bin/yarn
+
+ install -Dm644 "$srcdir"/dist/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}