summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Koppe2016-10-11 20:24:49 +0200
committerJan Koppe2016-10-11 20:24:49 +0200
commit9c5156883113674d53bb53ff6abe7ccd36708ed8 (patch)
treee9e3fb591e23a7c4c269ee91a9db16ef57514255
parent4d99bf1557dc6ecda8a47c3f8b58363419b54c2d (diff)
downloadaur-9c5156883113674d53bb53ff6abe7ccd36708ed8.tar.gz
remove unnecessary download, include license, include python dependency
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD11
3 files changed, 36 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 566dfd26b4ef..7f248064d5e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = yarn
pkgdesc = Fast, reliable, and secure dependency management.
pkgver = 0.15.1
- pkgrel = 1
+ pkgrel = 2
url = http://yarnpkg.com
arch = any
license = BSD
depends = npm
- noextract = yarnpkg-0.15.1.tgz
- source = http://registry.npmjs.org/yarnpkg/-/yarnpkg-0.15.1.tgz
- sha256sums = fc93a937956678ba1657adb9cd65208223cd49eff3e2060e670cfc29c0337002
+ depends = python
+ source = LICENSE
+ sha256sums = 3992e4db1e3af655b0413667c9e7089757154d46a36a94659f35fc090fdcf15a
pkgname = yarn
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..4ce2863a248a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,26 @@
+BSD License
+
+For Yarn software
+
+Copyright (c) 2016-present, Yarn Contributors. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification,
+are permitted provided that the following conditions are met:
+
+ * Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR
+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
+ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 5824472d21c1..3a657c8e153d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,18 @@ _npmname=yarnpkg
_npmver=0.15.1
pkgname=yarn
pkgver=0.15.1
-pkgrel=1
+pkgrel=2
pkgdesc='Fast, reliable, and secure dependency management.'
arch=(any)
url='http://yarnpkg.com'
license=('BSD')
-depends=('npm')
-source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
-noextract=($_npmname-$_npmver.tgz)
-sha256sums=('fc93a937956678ba1657adb9cd65208223cd49eff3e2060e670cfc29c0337002')
+depends=('npm' 'python')
+source=('LICENSE')
+sha256sums=('3992e4db1e3af655b0413667c9e7089757154d46a36a94659f35fc090fdcf15a')
package() {
+ mkdir -p "$pkgdir/usr/share/licenses/yarn"
+ cp "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/yarn/LICENSE"
cd "$srcdir"
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p "$_npmdir"