summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-06-16 12:03:42 +0200
committerFabioLolix2018-06-16 12:03:42 +0200
commit9b529ab81c6669d1cf844df798c123873a240b2b (patch)
tree897159f6fc1b099ae2963a4ce547378c8eed755d
downloadaur-9b529ab81c6669d1cf844df798c123873a240b2b.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c5d1b394a88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = yarock-mpv
+ pkgdesc = Qt Modern Music Player with collection browse based on cover art, using only the mpv engine
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://launchpad.net/yarock
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = qt5-tools
+ makedepends = qt5-x11extras
+ depends = qt5-base
+ depends = htmlcxx
+ depends = taglib>=1.10
+ depends = mpv
+ provides = yarock
+ conflicts = yarock
+ conflicts = yarock-qt5
+ source = https://launchpad.net/yarock/1.x/1.3.1/+download/Yarock_1.3.1_Sources.tar.gz
+ md5sums = c20d028a8f6f0b946270e6dace39f708
+
+pkgname = yarock-mpv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76e6145744c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: Košava <kosava at archlinux dot us>
+
+pkgname=yarock-mpv
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Qt Modern Music Player with collection browse based on cover art, using only the mpv engine"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/yarock"
+license=('GPL3')
+depends=('qt5-base' 'htmlcxx' 'taglib>=1.10' 'mpv')
+makedepends=('cmake' 'qt5-tools' 'qt5-x11extras')
+provides=('yarock')
+conflicts=('yarock' 'yarock-qt5')
+source=("https://launchpad.net/yarock/1.x/${pkgver}/+download/Yarock_${pkgver}_Sources.tar.gz")
+md5sums=('c20d028a8f6f0b946270e6dace39f708')
+
+prepare() {
+ rm -rf "build"
+ mkdir "build"
+}
+
+build() {
+ cd build
+ cmake "../Yarock_${pkgver}_Sources" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_QT5=1 \
+ -DENABLE_MPV=ON \
+ -DENABLE_VLC=OFF \
+ -DENABLE_PHONON=OFF \
+ -DTAGLIB_MIN_VERSION=1.10
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}