summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcan1s2015-06-08 19:57:12 +0300
committerarcan1s2015-06-08 19:57:12 +0300
commit5fbdbb43577b13412df7fd0e80d88fb8e3bd0bee (patch)
tree12d5f390c6fee9f5ac4b59a0da0fca4390dba801
downloadaur-5fbdbb43577b13412df7fd0e80d88fb8e3bd0bee.tar.gz
upload yarock-qt5
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
-rw-r--r--phonon.patch12
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5c3596f90b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = yarock-qt5
+ pkgdesc = Qt Modern Music Player with collection browse based on cover art
+ pkgver = 1.1.2
+ pkgrel = 2
+ url = https://launchpad.net/yarock
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = mpv
+ depends = qt5-x11extras
+ depends = phonon-qt5
+ depends = taglib
+ optdepends = mpv: alternative (working) engine
+ source = https://launchpad.net/yarock/1.x/1.1.2/+download/Yarock_1.1.2_source.tar.gz
+ source = phonon.patch
+ md5sums = 88733d9bed252c132a378dfecb158697
+ md5sums = d6f84a05159c8b7035723cbdeb6fc611
+
+pkgname = yarock-qt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a0c475d6d41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: Košava <kosava at archlinux dot us>
+
+pkgname=yarock-qt5
+pkgver=1.1.2
+pkgrel=2
+pkgdesc="Qt Modern Music Player with collection browse based on cover art"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/yarock"
+license=('GPL3')
+makedepends=('cmake' 'mpv')
+depends=('qt5-x11extras' 'phonon-qt5' 'taglib')
+optdepends=('mpv: alternative (working) engine')
+source=("https://launchpad.net/yarock/1.x/${pkgver}/+download/Yarock_${pkgver}_source.tar.gz"
+ "phonon.patch")
+md5sums=('88733d9bed252c132a378dfecb158697'
+ 'd6f84a05159c8b7035723cbdeb6fc611')
+
+prepare() {
+ patch -p0 -i "${srcdir}/phonon.patch"
+}
+
+build() {
+ mkdir build
+ cd build
+ cmake "../Yarock_${pkgver}_source" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_QT5=1 \
+ -DENABLE_MPV=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/phonon.patch b/phonon.patch
new file mode 100644
index 000000000000..15682b01f1e0
--- /dev/null
+++ b/phonon.patch
@@ -0,0 +1,12 @@
+diff -ruN Yarock_1.1.2_source-orig/src/core/player/phonon/CMakeLists.txt Yarock_1.1.2_source/src/core/player/phonon/CMakeLists.txt
+--- Yarock_1.1.2_source-orig/src/core/player/phonon/CMakeLists.txt 2015-05-21 00:42:46.627611703 +0300
++++ Yarock_1.1.2_source/src/core/player/phonon/CMakeLists.txt 2015-05-21 00:43:25.852867232 +0300
+@@ -34,7 +34,7 @@
+
+
+ if (ENABLE_QT5)
+- INCLUDE_DIRECTORIES( ${PHONON_INCLUDE_DIR}/phonon4qt5 )
++ INCLUDE_DIRECTORIES( /usr/include/phonon4qt5 )
+ else (ENABLE_QT5)
+ INCLUDE_DIRECTORIES( ${PHONON_INCLUDES} )
+ endif (ENABLE_QT5)