summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Souza2023-02-12 05:42:17 -0300
committerDaniel Souza2023-02-12 05:42:17 -0300
commit0b1baba2183ca6ee76e0288f119ab155f9435776 (patch)
treedd9f5b902907b51bf4940f6a908e01948c69900f
parentfba47a2e5dc999119c8230c6f7a5ccc4c2f51122 (diff)
downloadaur-0b1baba2183ca6ee76e0288f119ab155f9435776.tar.gz
Refactor PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b604adfff4d0..db86ce6d7e82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = yarr-git
pkgdesc = Self-hosted RSS reader with Vue.js front and Go/SQLite back.
pkgver = v2.3.r41.g95ebbb9
- pkgrel = 4
+ pkgrel = 2
url = https://github.com/nkanaev/yarr
arch = any
license = MIT
makedepends = go
makedepends = make
makedepends = git
- source = git+https://github.com/nkanaev/yarr.git#branch=main
- sha1sums = SKIP
+ provides = yarr
+ source = git+https://github.com/nkanaev/yarr.git#branch=master
+ sha512sums = SKIP
pkgname = yarr-git
diff --git a/PKGBUILD b/PKGBUILD
index d58c0c504c89..2bd3bb47dda3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,18 +7,29 @@ _outdir="_output/linux"
pkgname="${_pkgname}-git"
pkgver=v2.3.r41.g95ebbb9
-pkgrel=1
+pkgrel=2
pkgdesc="Self-hosted RSS reader with Vue.js front and Go/SQLite back."
arch=("any")
url="https://github.com/${_gitauthor}/${_pkgname}"
license=("MIT")
-source=("git+https://github.com/${_gitauthor}/${_pkgname}.git#branch=${_gitbranch}")
+groups=()
depends=()
makedepends=("go" "make" "git")
-sha1sums=("SKIP")
+optdepends=()
+provides=("${_pkgname%}")
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/${_gitauthor}/${_pkgname}.git#branch=${_gitbranch}")
+noextract=()
+sha512sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
+ # Use tags but fallback to revision
( set -o pipefail
git describe --tags --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"