summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-01-15 10:52:39 -0700
committeryochananmarqos2020-01-15 10:52:39 -0700
commit41b62cc8537994993baaf22badf98608459c91fc (patch)
treee2cb2d08966f667727e399f98b83691fabf20216
parentd5c35ede97e22c9387fe49318695fb693bf0c219 (diff)
downloadaur-41b62cc8537994993baaf22badf98608459c91fc.tar.gz
updated for upstream changes, added icons and wallpaper packages
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD68
2 files changed, 71 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3a6e6ed3d79..d5c2dc745904 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,35 @@
pkgbase = yaru-colors-gtk-theme-git
pkgdesc = A fork of Ubuntu's Yaru theme - in different colors
- pkgver = cbc4598
+ pkgver = 2.0.r13.3ac6559
pkgrel = 1
url = https://github.com/Jannomag/Yaru-Colors
- arch = x86_64
- license = MIT
+ arch = any
+ license = GPL3
makedepends = git
- provides = adwaita-creamy
source = git+https://github.com/Jannomag/Yaru-Colors.git
sha256sums = SKIP
pkgname = yaru-colors-gtk-theme-git
+ depends = gtk3
+ depends = gdk-pixbuf2
+ depends = gtk-engine-murrine
+ depends = gnome-themes-extra
+ depends = gnome-shell
+ optdepends = yaru-colors-wallpapers
+ optdepends = yaru-colors-icon-theme
+ optdepends = yaru-sound-theme
+ provides = yaru-colors-gtk-theme
+ conflicts = yaru-colors-gtk-theme
+
+pkgname = yaru-colors-icon-theme-git
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = librsvg
+ depends = humanity-icon-theme
+ provides = yaru-colors-icon-theme
+ conflicts = yaru-colors-icon-theme
+
+pkgname = yaru-colors-wallpapers-git
+ provides = yaru-colors-wallpapers
+ conflicts = yaru-colors-wallpapers
diff --git a/PKGBUILD b/PKGBUILD
index 0bd091615505..05e38eefe416 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,50 @@
-# Maintainer: toluschr at protonmail dot com
-
-pkgname="yaru-colors-gtk-theme-git"
-pkgver="cbc4598"
-pkgrel="1"
-pkgdesc="A fork of Ubuntu's Yaru theme - in different colors "
-arch=("x86_64")
-license=("MIT")
+# Maintainer: Mark Wagie <mark.wagie at tutanota dot com>
+# Contributor: toluschr <toluschr at protonmail dot com>
+pkgname=('yaru-colors-gtk-theme-git'
+ 'yaru-colors-icon-theme-git'
+ 'yaru-colors-wallpapers-git')
+pkgbase='yaru-colors-gtk-theme-git'
+pkgver=2.0.r13.3ac6559
+pkgrel=1
+pkgdesc="A fork of Ubuntu's Yaru theme - in different colors"
+arch=('any')
+license=('GPL3')
url="https://github.com/Jannomag/Yaru-Colors"
-makedepends=("git")
-provides=("adwaita-creamy")
+makedepends=('git')
+source=('git+https://github.com/Jannomag/Yaru-Colors.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/Yaru-Colors"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package_yaru-colors-gtk-theme-git() {
+ depends=('gtk3' 'gdk-pixbuf2' 'gtk-engine-murrine' 'gnome-themes-extra' 'gnome-shell')
+ optdepends=('yaru-colors-wallpapers' 'yaru-colors-icon-theme' 'yaru-sound-theme')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+
+ cd "$srcdir/Yaru-Colors"
+ install -d "$pkgdir/usr/share/themes"
+ cp -a Themes/* "$pkgdir/usr/share/themes"
+}
+
+package_yaru-colors-icon-theme-git() {
+ depends=('hicolor-icon-theme' 'gtk-update-icon-cache' 'librsvg' 'humanity-icon-theme')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
-source=("git+https://github.com/Jannomag/Yaru-Colors.git")
-sha256sums=("SKIP")
+ cd "$srcdir/Yaru-Colors"
+ install -d "$pkgdir/usr/share/icons"
+ cp -a Icons/* "$pkgdir/usr/share/icons"
+}
-package() {
- install -dm755 "$pkgdir/usr/share/themes"
- cd "$srcdir/Yaru-Colors/Themes"
- mv "Yaru-MATE -dark" "Yaru-MATE-dark"
+package_yaru-colors-wallpapers-git() {
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
- for themeVariant in $(ls)
- do
- echo "Installing -> $themeVariant"
- cp -rL "$srcdir/Yaru-Colors/Themes/$themeVariant" "$pkgdir/usr/share/themes/"
- done
-} \ No newline at end of file
+ cd "$srcdir/Yaru-Colors"
+ install -d "$pkgdir/usr/share/backgrounds/yaru-colors"
+ cp -a Wallpapers/* "$pkgdir/usr/share/backgrounds/yaru-colors"
+}