summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-02-03 08:33:45 -0700
committerMark Wagie2022-02-03 08:33:45 -0700
commit7c22261eefc7762670a4768aeb757b6e23510eb9 (patch)
tree7d7959fc113b5e317363b9cdb91c9198b32f11b7
parent5e121966672a62c16e93df88d9618aab94bed066 (diff)
downloadaur-7c22261eefc7762670a4768aeb757b6e23510eb9.tar.gz
adapt to upstream changes
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD67
2 files changed, 55 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e3614dfdb8d..71e90ec753ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,38 @@
pkgbase = yaru-colors-gtk-theme-git
pkgdesc = A fork of Ubuntu's Yaru theme - in different colors
pkgver = 21.10.3ubuntu5.r1.gcb79ae7c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Jannomag/Yaru-Colors
arch = any
license = GPL3
makedepends = git
- options = !strip
- source = git+https://github.com/Jannomag/Yaru-Colors.git#branch=what-if-21.10
- sha256sums = SKIP
-
-pkgname = yaru-colors-gtk-theme-git
+ makedepends = meson
+ makedepends = sassc
depends = gnome-themes-extra
optdepends = gdk-pixbuf2: GTK2 support
optdepends = gtk-engine-murrine: GTK2 support
- optdepends = yaru-colors-wallpapers: Matching wallpapers
- optdepends = yaru-colors-icon-theme: Matching icon theme
- optdepends = yaru-sound-theme: Matching sound theme
provides = yaru-colors-gtk-theme
- conflicts = yaru-colors-gtk-theme
-
-pkgname = yaru-colors-icon-theme-git
- depends = yaru-icon-theme
provides = yaru-colors-icon-theme
+ provides = yaru-gnome-shell-theme
+ provides = yaru-gtk-theme
+ provides = yaru-gtksourceview-theme
+ provides = yaru-icon-theme
+ provides = yaru-metacity-theme
+ provides = yaru-sound-theme
+ provides = yaru-unity-theme
+ provides = yaru-xfwm4-theme
+ conflicts = yaru-colors-gtk-theme
conflicts = yaru-colors-icon-theme
+ conflicts = yaru-gnome-shell-theme
+ conflicts = yaru-gtk-theme
+ conflicts = yaru-gtksourceview-theme
+ conflicts = yaru-icon-theme
+ conflicts = yaru-metacity-theme
+ conflicts = yaru-sound-theme
+ conflicts = yaru-unity-theme
+ conflicts = yaru-xfwm4-theme
+ options = !strip
+ source = git+https://github.com/Jannomag/Yaru-Colors.git#branch=what-if-21.10
+ sha256sums = SKIP
-pkgname = yaru-colors-wallpapers-git
- provides = yaru-colors-wallpapers
- conflicts = yaru-colors-wallpapers
+pkgname = yaru-colors-gtk-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index d3948e3b3d1a..db65ecd2934c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,36 @@
# Maintainer: Mark Wagie <mark.wagie at tutanota dot com>
# Contributor: toluschr <toluschr at protonmail dot com>
-pkgname=('yaru-colors-gtk-theme-git'
- 'yaru-colors-icon-theme-git'
- 'yaru-colors-wallpapers-git')
-pkgbase='yaru-colors-gtk-theme-git'
+pkgname=yaru-colors-gtk-theme-git
pkgver=21.10.3ubuntu5.r1.gcb79ae7c
-pkgrel=1
+pkgrel=2
pkgdesc="A fork of Ubuntu's Yaru theme - in different colors"
arch=('any')
license=('GPL3')
url="https://github.com/Jannomag/Yaru-Colors"
-makedepends=('git')
+depends=('gnome-themes-extra')
+makedepends=('git' 'meson' 'sassc')
+optdepends=('gdk-pixbuf2: GTK2 support'
+ 'gtk-engine-murrine: GTK2 support')
+provides=("${pkgname%-git}"
+ 'yaru-colors-icon-theme'
+ 'yaru-gnome-shell-theme'
+ 'yaru-gtk-theme'
+ 'yaru-gtksourceview-theme'
+ 'yaru-icon-theme'
+ 'yaru-metacity-theme'
+ 'yaru-sound-theme'
+ 'yaru-unity-theme'
+ 'yaru-xfwm4-theme')
+conflicts=("${pkgname%-git}"
+ 'yaru-colors-icon-theme'
+ 'yaru-gnome-shell-theme'
+ 'yaru-gtk-theme'
+ 'yaru-gtksourceview-theme'
+ 'yaru-icon-theme'
+ 'yaru-metacity-theme'
+ 'yaru-sound-theme'
+ 'yaru-unity-theme'
+ 'yaru-xfwm4-theme')
options=('!strip')
source=('git+https://github.com/Jannomag/Yaru-Colors.git#branch=what-if-21.10')
sha256sums=('SKIP')
@@ -20,36 +40,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/snap//'
}
-package_yaru-colors-gtk-theme-git() {
- depends=('gnome-themes-extra')
- optdepends=('gdk-pixbuf2: GTK2 support'
- 'gtk-engine-murrine: GTK2 support'
- 'yaru-colors-wallpapers: Matching wallpapers'
- 'yaru-colors-icon-theme: Matching icon theme'
- 'yaru-sound-theme: Matching sound theme')
- provides=("${pkgname%-git}")
- conflicts=("${pkgname%-git}")
-
- cd "$srcdir/Yaru-Colors"
- install -d "$pkgdir/usr/share/themes"
- cp -a Themes/* "$pkgdir/usr/share/themes"
-}
-
-package_yaru-colors-icon-theme-git() {
- depends=('yaru-icon-theme')
- provides=("${pkgname%-git}")
- conflicts=("${pkgname%-git}")
-
- cd "$srcdir/Yaru-Colors"
- install -d "$pkgdir/usr/share/icons"
- cp -a Icons/* "$pkgdir/usr/share/icons"
+build() {
+ arch-meson Yaru-Colors build
+ meson compile -C build
}
-package_yaru-colors-wallpapers-git() {
- provides=("${pkgname%-git}")
- conflicts=("${pkgname%-git}")
-
- cd "$srcdir/Yaru-Colors"
- install -d "$pkgdir/usr/share/backgrounds/yaru-colors"
- cp -a Wallpapers/* "$pkgdir/usr/share/backgrounds/yaru-colors"
+package() {
+ meson install -C build --destdir "$pkgdir"
}