summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2019-10-22 23:00:16 -0400
committerchrisjbillington2019-10-22 23:01:27 -0400
commit2c14a08af7db1212649f81ba508aa6564eaffc0e (patch)
treee1b7da5dffc85707cde90cc6b821ff60a63e708e
parent9e47ea0dbfd130fb9e9a084335d028b6e7178d78 (diff)
downloadaur-2c14a08af7db1212649f81ba508aa6564eaffc0e.tar.gz
Update for new directory structure, modify link creation script.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
-rw-r--r--install-shell.sh9
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cdd8f37721d..7dcdbd84a9c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yaru-git
pkgdesc = Yaru default ubuntu theme
- pkgver = 18.10.7.r288.g93c13b3e
+ pkgver = 19.10.4.r23.gab1bd973
pkgrel = 1
url = https://github.com/ubuntu/yaru
arch = any
@@ -12,7 +12,9 @@ pkgbase = yaru-git
options = !buildflags
options = staticlibs
source = git+https://github.com/ubuntu/yaru
+ source = install-shell.sh
sha256sums = SKIP
+ sha256sums = 8b6aa29d87c5685fa5f968fae5c614bb45383016839968828ccaa02ceea3fdb1
pkgname = yaru-sound-theme-git
pkgdesc = Yaru default ubuntu sound theme
diff --git a/PKGBUILD b/PKGBUILD
index 25f17a7fdd72..01df069a2a86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Chris Billington <chrisjbillington@gmail.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgbase=yaru-git
@@ -7,7 +8,7 @@ pkgname=(yaru-sound-theme-git
yaru-gnome-shell-theme-git
yaru-icon-theme-git
yaru-session-git)
-pkgver=18.10.7.r288.g93c13b3e
+pkgver=19.10.4.r23.gab1bd973
pkgrel=1
pkgdesc="Yaru default ubuntu theme"
arch=(any)
@@ -15,15 +16,19 @@ url="https://github.com/ubuntu/yaru"
license=('GPL3')
makedepends=(meson sassc git)
options=('!strip' '!buildflags' 'staticlibs')
-source=("git+https://github.com/ubuntu/yaru")
-sha256sums=('SKIP')
-
+source=("git+https://github.com/ubuntu/yaru" "install-shell.sh")
+sha256sums=('SKIP' '8b6aa29d87c5685fa5f968fae5c614bb45383016839968828ccaa02ceea3fdb1')
pkgver() {
cd yaru
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ # Workaround issue https://github.com/ubuntu/yaru/issues/1583 for now:
+ cp install-shell.sh "${srcdir}/yaru/gnome-shell/src/"
+}
+
build() {
arch-meson yaru build
ninja -C build
@@ -56,6 +61,8 @@ package_yaru-gtk-theme-git() {
rm -r "$pkgdir/usr/share/icons"
rm -r "$pkgdir/usr/share/sounds"
rm -r "$pkgdir/usr/share/gnome-shell"
+ rm -r "$pkgdir/usr/share/themes/Yaru/gnome-shell"
+ rm -r "$pkgdir/usr/share/themes/Yaru-dark/gnome-shell"
}
package_yaru-gnome-shell-theme-git() {
@@ -70,7 +77,8 @@ package_yaru-gnome-shell-theme-git() {
rm -r "$pkgdir/usr/share/wayland-sessions"
rm -r "$pkgdir/usr/share/icons"
rm -r "$pkgdir/usr/share/sounds"
- rm -r "$pkgdir/usr/share/themes"
+ rm -r "$pkgdir/usr/share/themes/Yaru-light"
+ rm -r "$pkgdir/usr/share/themes/Yaru"{,-dark}/{gtk-{2.0,3.0,3.20},index.theme}
}
package_yaru-icon-theme-git() {
@@ -99,4 +107,4 @@ package_yaru-session-git() {
rm -r "$pkgdir/usr/share/themes"
rm -r "$pkgdir/usr/share/gnome-shell"
rm -r "$pkgdir/usr/share/icons"
-}
+} \ No newline at end of file
diff --git a/install-shell.sh b/install-shell.sh
new file mode 100644
index 000000000000..c857bc216f1f
--- /dev/null
+++ b/install-shell.sh
@@ -0,0 +1,9 @@
+#!/usr/bin/env bash
+# -*- coding: UTF-8 -*-
+
+project_name="$1"
+destdir_prefix="${MESON_INSTALL_DESTDIR_PREFIX}/share"
+install_prefix="${MESON_INSTALL_PREFIX}/share"
+
+mkdir -p "${destdir_prefix}/gnome-shell/theme/"
+ln -sf "${install_prefix}/themes/${project_name}/gnome-shell" "${destdir_prefix}/gnome-shell/theme/${project_name}" \ No newline at end of file