summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2019-10-23 10:53:43 -0400
committerchrisjbillington2019-10-23 10:53:43 -0400
commit56297d7f58e5cddf86b856010089032680a3b57b (patch)
treee3a8d7c3c89a5a507bce98326f87b093744a0085
parentd5534a14e977148c2a67e244eaa76f8b190d58a5 (diff)
downloadaur-56297d7f58e5cddf86b856010089032680a3b57b.tar.gz
Shell theme does not depend on session. Session depends on shell theme.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 3 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c6839f1c7b9..2220d3c16254 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -31,7 +31,6 @@ pkgname = yaru-gtk-theme-git
pkgname = yaru-gnome-shell-theme-git
pkgdesc = Yaru default ubuntu gnome shell theme
depends = gnome-shell
- depends = yaru-session
provides = yaru-gnome-shell-theme
conflicts = yaru-gnome-shell-theme
@@ -46,6 +45,7 @@ pkgname = yaru-icon-theme-git
pkgname = yaru-session-git
pkgdesc = Yaru session
depends = gnome-shell
+ depends = yaru-gnome-shell-theme
provides = yaru-session
conflicts = yaru-session
diff --git a/PKGBUILD b/PKGBUILD
index af1f0d3ed772..2d17437b364a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,23 +31,18 @@ build() {
_delete_all_from_pkgdir_except() {
if [[ "$1" != "sound-theme" ]]; then
- echo "deleting sound theme"
rm -r "${pkgdir}"/usr/share/sounds
fi
if [[ "$1" != "gtk-theme" ]]; then
- echo "deleting gtk theme"
rm -r "${pkgdir}"/usr/share/themes/Yaru{-light,{,-dark}/{gtk-*,index.theme}}
fi
if [[ "$1" != "gnome-shell-theme" ]]; then
- echo "deleting shell theme"
rm -r "${pkgdir}"/usr/share/{gnome-shell,themes/Yaru{,-dark}/gnome-shell}
fi
if [[ "$1" != "icon-theme" ]]; then
- echo "deleting icon theme"
rm -r "${pkgdir}"/usr/share/icons
fi
if [[ "$1" != "session" ]]; then
- echo "deleting session"
rm -r "${pkgdir}"/usr/share/{glib-2.0,xsessions,wayland-sessions}
fi
}
@@ -73,7 +68,7 @@ package_yaru-gtk-theme-git() {
package_yaru-gnome-shell-theme-git() {
pkgdesc="Yaru default ubuntu gnome shell theme"
- depends=(gnome-shell yaru-session)
+ depends=(gnome-shell)
provides=(yaru-gnome-shell-theme)
conflicts=(yaru-gnome-shell-theme)
@@ -93,7 +88,7 @@ package_yaru-icon-theme-git() {
package_yaru-session-git() {
pkgdesc="Yaru session"
- depends=(gnome-shell)
+ depends=(gnome-shell yaru-gnome-shell-theme)
provides=(yaru-session)
conflicts=(yaru-session)