summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2019-12-23 05:18:01 -0500
committerchrisjbillington2019-12-23 05:18:01 -0500
commitd4716946f53110f9e59fac7ad8de9f1ffda2e2be (patch)
tree2578457add4ecf832ff754cd4c6df918d60bfdf0
parente0e56cba6a2552440bf3e7f017c98f85de328c9d (diff)
downloadaur-d4716946f53110f9e59fac7ad8de9f1ffda2e2be.tar.gz
Add yaru-unity-theme-git
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3184444d3dcf..fb056791633e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yaru-git
pkgdesc = Yaru default ubuntu theme
- pkgver = 19.10.4.r34.g2d2cf90a
- pkgrel = 3
+ pkgver = 19.10.4.r109.g00e439fc
+ pkgrel = 1
url = https://github.com/ubuntu/yaru
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 966c140c2ee9..0b4da16b0843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@ pkgname=(yaru-sound-theme-git
yaru-gnome-shell-theme-git
yaru-icon-theme-git
yaru-session-git)
-pkgver=19.10.4.r34.g2d2cf90a
-pkgrel=3
+pkgver=19.10.4.r109.g00e439fc
+pkgrel=1
pkgdesc="Yaru default ubuntu theme"
arch=(any)
url="https://github.com/ubuntu/yaru"
@@ -40,6 +40,9 @@ _delete_all_from_pkgdir_except() {
rm -r "${pkgdir}"/usr/share/themes/Yaru{,-dark}/gnome-shell
rm -r "${pkgdir}"/usr/share/gnome-shell/theme/Yaru
fi
+ if [[ "$1" != "unity-theme" ]]; then
+ rm -r "${pkgdir}"/usr/share/themes/Yaru{,-dark}/unity
+ fi
if [[ "$1" != "icon-theme" ]]; then
rm -r "${pkgdir}"/usr/share/icons
fi
@@ -80,6 +83,15 @@ package_yaru-gnome-shell-theme-git() {
_delete_all_from_pkgdir_except "gnome-shell-theme"
}
+package_yaru-unity-theme-git() {
+ pkgdesc="Yaru default ubuntu unity theme"
+ provides=(yaru-unity-theme)
+ conflicts=(yaru-unity-theme)
+
+ DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
+ _delete_all_from_pkgdir_except "unity-theme"
+}
+
package_yaru-icon-theme-git() {
pkgdesc="Yaru default ubuntu icon theme"
depends=(hicolor-icon-theme gtk-update-icon-cache librsvg)