summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2021-01-12 23:10:04 +0100
committerChristian Schendel2021-01-12 23:10:04 +0100
commitb8c74e00d34f0c6ff20b32743aaedd869eaafd92 (patch)
tree56f246ecd870697d2be6ffe61d23691dee52fd6a
downloadaur-b8c74e00d34f0c6ff20b32743aaedd869eaafd92.tar.gz
initial commit
-rw-r--r--.SRCINFO48
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD90
3 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1bd458029da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = yaru-remix-git
+ pkgdesc = Yaru-remix is a fork of Yaru theme
+ pkgver = 20.10.1.r65.g23b4478a
+ pkgrel = 1
+ url = https://github.com/Muqtxdir/yaru-remix-gtk-theme
+ arch = any
+ license = GPL3
+ license = LGPL3
+ license = LGPL2.1
+ license = CCPL:by-nc-sa
+ makedepends = meson
+ makedepends = sassc
+ makedepends = git
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = yaru-remix::git+https://github.com/Muqtxdir/yaru-remix.git
+ sha256sums = SKIP
+
+pkgname = yaru-remix-gtk-theme-git
+ pkgdesc = Yaru-remix gtk theme
+ depends = gtk3
+ depends = gdk-pixbuf2
+ depends = gtk-engine-murrine
+ depends = gnome-themes-extra
+ provides = yaru-remix-gtk-theme
+ conflicts = yaru-remix-gtk-theme-git
+
+pkgname = yaru-remix-gnome-shell-theme-git
+ pkgdesc = Yaru-remix gnome shell theme
+ depends = gnome-shell
+ provides = yaru-remix-gnome-shell-theme
+ conflicts = yaru-remix-gnome-shell-theme
+
+pkgname = yaru-remix-icon-theme-git
+ pkgdesc = Yaru-remix icon theme
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = librsvg
+ depends = humanity-icon-theme
+ provides = yaru-remix-icon-theme
+ conflicts = yaru-remix-icon-theme
+
+pkgname = yaru-remix-wallpaper-git
+ pkgdesc = Yaru-remix wallpaper theme
+ provides = yaru-remix-wallpaper
+ conflicts = yaru-remix-wallpaper
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..833085309a2e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar.zst
+*/*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23aee72f721e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: Christian Schendel <doppelhelix@gmail.com>
+pkgbase=yaru-remix-git
+pkgname=(yaru-remix-gtk-theme-git
+ yaru-remix-gnome-shell-theme-git
+ yaru-remix-icon-theme-git
+ yaru-remix-wallpaper-git)
+pkgver=20.10.1.r65.g23b4478a
+pkgrel=1
+pkgdesc="Yaru-remix is a fork of Yaru theme"
+arch=(any)
+url="https://github.com/Muqtxdir/${pkgname%-git}"
+license=('GPL3' 'LGPL3' 'LGPL2.1' 'CCPL:by-nc-sa')
+makedepends=(meson sassc git)
+options=('!strip' '!buildflags' 'staticlibs')
+source=("${pkgbase%-git}::git+https://github.com/Muqtxdir/yaru-remix.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgbase%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson yaru-remix build
+ meson configure build
+ ninja -C build
+}
+
+_delete_all_from_pkgdir_except() {
+ if [[ "$1" != "gtk-theme" ]]; then
+ rm -r "${pkgdir}"/usr/share/themes/Yaru-remix-light/{gtk-*,index.theme}
+ rm -r "${pkgdir}"/usr/share/themes/Yaru-remix-dark/{gtk-*,index.theme}
+ rm -r "${pkgdir}"/usr/share/themes/Yaru-remix/{gtk-*,index.theme}
+ fi
+ if [[ "$1" != "gnome-shell-theme" ]]; then
+ rm -r "${pkgdir}"/usr/share/themes/Yaru-remix/gnome-shell
+ rm -r "${pkgdir}"/usr/share/themes/Yaru-remix-light/gnome-shell
+ rm -r "${pkgdir}"/usr/share/themes/Yaru-remix-dark/gnome-shell
+ rm -r "${pkgdir}"/usr/share/gnome-shell
+ fi
+ if [[ "$1" != "icon-theme" ]]; then
+ rm -r "${pkgdir}"/usr/share/icons
+ fi
+ if [[ "$1" != "wallpaper" ]]; then
+ rm -r "${pkgdir}"/usr/share/backgrounds
+ rm -r "${pkgdir}"/usr/share/gnome-background-properties
+ fi
+ # Delete remaining empty directories:
+ find "${pkgdir}" -type d -empty -delete
+}
+
+package_yaru-remix-gtk-theme-git() {
+ pkgdesc="Yaru-remix gtk theme"
+ depends=(gtk3 gdk-pixbuf2 gtk-engine-murrine gnome-themes-extra)
+ provides=(yaru-remix-gtk-theme)
+ conflicts=(yaru-remix-gtk-theme-git)
+
+ DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
+ _delete_all_from_pkgdir_except "gtk-theme"
+}
+
+package_yaru-remix-gnome-shell-theme-git() {
+ pkgdesc="Yaru-remix gnome shell theme"
+ depends=(gnome-shell)
+ provides=(yaru-remix-gnome-shell-theme)
+ conflicts=(yaru-remix-gnome-shell-theme)
+
+ DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
+ _delete_all_from_pkgdir_except "gnome-shell-theme"
+}
+
+package_yaru-remix-icon-theme-git() {
+ pkgdesc="Yaru-remix icon theme"
+ depends=(hicolor-icon-theme gtk-update-icon-cache librsvg humanity-icon-theme)
+ provides=(yaru-remix-icon-theme)
+ conflicts=(yaru-remix-icon-theme)
+
+ DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
+ _delete_all_from_pkgdir_except "icon-theme"
+}
+
+package_yaru-remix-wallpaper-git() {
+ pkgdesc="Yaru-remix wallpaper theme"
+ provides=(yaru-remix-wallpaper)
+ conflicts=(yaru-remix-wallpaper)
+
+ DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
+ _delete_all_from_pkgdir_except "wallpaper"
+}
+