summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorur name2020-09-27 16:37:05 +0000
committerur name2020-09-27 16:37:05 +0000
commit9e1319704329c4bdd335371224f13ef82d6caefc (patch)
tree572ca8a9f562fb1eb559abef636cf0b6b6d44938
downloadaur-9e1319704329c4bdd335371224f13ef82d6caefc.tar.gz
First commit with all the files
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dd86ce975ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = yas-git
+ pkgdesc = A sudo replacement, written in rust
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/alx365/yas
+ arch = any
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ source = yas-git::git+https://github.com/alx365/yas
+ sha256sums = SKIP
+
+pkgname = yas-git
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d01833c2f15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# PKGBUILD created by using cargo-aur
+pkgname='yas-git'
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A sudo replacement, written in rust'
+arch=('any')
+url='https://github.com/alx365/yas'
+license=('MIT')
+sha256sums=('SKIP')
+makedepends=('rust' 'cargo' 'git')
+source=('yas-git::git+https://github.com/alx365/yas')
+
+pkgver() {
+ cd "$pkgname"
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)" | tr '-' '.'
+}
+
+build() {
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+check() {
+ cargo test --release --locked --target-dir=target
+}
+
+package() {
+ install -Dm 755 target/release/yas -t "${pkgdir}/usr/bin"
+ # install -Dm 755 $pkgname/LICENSE "${pkgdir}/usr/share/licenses/yas"
+}
+