summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpoly0002023-01-11 14:38:52 +0800
committerpoly0002023-01-11 14:38:52 +0800
commita0fb8ea12fe89d9bb4672a836d53ce2fd54dc551 (patch)
tree3bc0ee338978dd3274e642d3b317b9f8e304c07c
downloadaur-a0fb8ea12fe89d9bb4672a836d53ce2fd54dc551.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD43
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68f114d15253
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = yas-scanner
+ pkgdesc = fast Artifact scanner for an specific anime game works well with GNOME/Wayland and all on X11
+ pkgver = 0.1.11.a716391
+ pkgrel = 1
+ url = https://github.com/poly000/yas/tree/linux-x11-support
+ arch = any
+ license = unknown
+ makedepends = cargo
+ depends = xorg-xwininfo
+ depends = libxcb
+ depends = libx11
+ depends = libxrandr
+ provides = yas-scanner
+
+pkgname = yas-scanner
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5e4ca524e5b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+
+*.pkg.*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f268fc02a47d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: poly000 <1348292515@qq.com>
+pkgname=yas-scanner
+pkgver=0.1.11.a716391
+pkgrel=1
+pkgdesc="fast Artifact scanner for an specific anime game works well with GNOME/Wayland and all on X11"
+
+arch=('any')
+
+url="https://github.com/poly000/yas/tree/linux-x11-support"
+license=(unknown)
+depends=(xorg-xwininfo libxcb libx11 libxrandr)
+makedepends=("cargo")
+provides=("yas-scanner")
+source=()
+
+prepare() {
+ if [ -d "yas" ]
+ then
+ cd yas
+ git pull
+ else
+ git clone https://github.com/poly000/yas --branch linux-x11-support --depth 1
+ fi
+}
+
+pkgver() {
+ cd yas
+ echo 0.1.11.$(git describe --always)
+}
+
+build() {
+ if [[ $CARCH != x86_64 ]]; then
+ export CARGO_PROFILE_RELEASE_LTO=off
+ fi
+
+ cd yas
+ cargo build --release --locked --target-dir target
+}
+
+package() {
+ cd yas
+ install -Dm755 target/release/yas ${pkgdir}/usr/bin/yas-scanner
+}