summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-12 16:40:49 +0800
committerChocobo12017-08-12 16:48:53 +0800
commit32e00914c9afe955ead9dfd1a6a5482cb9338f2a (patch)
treef131abec3ef67ce3bf81d0654e2d95e66b5beded
downloadaur-32e00914c9afe955ead9dfd1a6a5482cb9338f2a.tar.gz
newpkg: yasm-git 1.3.0.r30.g6caf1518-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f67a894bd968
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yasm-git
+ pkgdesc = A complete rewrite of the NASM assembler under the BSD License
+ pkgver = 1.3.0.r30.g6caf1518
+ pkgrel = 1
+ url = http://yasm.tortall.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = glibc
+ provides = yasm
+ conflicts = yasm
+ source = git+https://github.com/yasm/yasm.git
+ sha256sums = SKIP
+
+pkgname = yasm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e1617e1c8ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=yasm-git
+pkgver=1.3.0.r30.g6caf1518
+pkgrel=1
+pkgdesc="A complete rewrite of the NASM assembler under the BSD License"
+arch=('i686' 'x86_64')
+url="http://yasm.tortall.net/"
+license=('BSD')
+depends=('glibc')
+makedepends=('git')
+provides=('yasm')
+conflicts=('yasm')
+source=("git+https://github.com/yasm/yasm.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "yasm"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "yasm"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "yasm"
+
+ #make check
+}
+
+package() {
+ cd "yasm"
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/yasm/COPYING"
+ install -Dm644 "BSD.txt" "$pkgdir/usr/share/licenses/yasm/BSD.txt"
+}