summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-01-30 10:54:17 +0800
committerChocobo12021-01-30 10:54:17 +0800
commit69e8edf793c37f8f5034b28cfd89c94aed1ec953 (patch)
treea1abbe2fbc2b6c9df17cee3bf7cbba997d6578de
parent856fb7a5bb0fa736fc4917cf3cc5d42127970109 (diff)
downloadaur-69e8edf793c37f8f5034b28cfd89c94aed1ec953.tar.gz
upgpkg: yasm-git 1.3.0.r48.g009450c7-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e878553a99b3..dce74f6801cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = yasm-git
pkgdesc = A complete rewrite of the NASM assembler under the BSD License
- pkgver = 1.3.0.r36.ge256985c
+ pkgver = 1.3.0.r48.g009450c7
pkgrel = 1
url = https://yasm.tortall.net/
arch = i686
arch = x86_64
license = BSD
makedepends = git
+ makedepends = cmake
depends = glibc
provides = yasm
conflicts = yasm
+ options = staticlibs
source = git+https://github.com/yasm/yasm.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4e945299b63c..42383d7652bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=yasm-git
-pkgver=1.3.0.r36.ge256985c
+pkgver=1.3.0.r48.g009450c7
pkgrel=1
pkgdesc="A complete rewrite of the NASM assembler under the BSD License"
arch=('i686' 'x86_64')
url="https://yasm.tortall.net/"
license=('BSD')
depends=('glibc')
-makedepends=('git')
+makedepends=('git' 'cmake')
provides=('yasm')
conflicts=('yasm')
+options=('staticlibs')
source=("git+https://github.com/yasm/yasm.git")
sha256sums=('SKIP')
@@ -24,22 +25,25 @@ pkgver() {
build() {
cd "yasm"
- ./autogen.sh
- ./configure --prefix="/usr"
- make
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_SHARED_LIBS=OFF \
+ ./
+ make -C "_build"
}
check() {
cd "yasm"
- #make check
+ #make -C "_build" test
}
package() {
cd "yasm"
- make DESTDIR="$pkgdir" install
-
- install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/yasm/COPYING"
- install -Dm644 "BSD.txt" "$pkgdir/usr/share/licenses/yasm/BSD.txt"
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 {BSD.txt,COPYING} -t "$pkgdir/usr/share/licenses/yasm"
}