summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeeyou2024-05-11 10:39:35 +0800
committerKeeyou2024-05-11 10:42:05 +0800
commitb6ab07995697e6152245e145a8fb01f4c195d60d (patch)
treef0a3700db8ee1df8d92f4b44a889d24eb4707a5a
parenta3894b0f76c66cf26f08e5a1599c9b0303296e92 (diff)
downloadaur-b6ab07995697e6152245e145a8fb01f4c195d60d.tar.gz
update for 1.9.5-r2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--boringssl-gcc-14.patch22
-rw-r--r--libcxx-gcc-14.patch13
4 files changed, 51 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd9508fd71ec..59e9a6e7432f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yass-proxy
pkgdesc = lightweight http/socks proxy
pkgver = 1.9.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Chilledheart/yass
arch = x86_64
license = GPL-2.0-only
@@ -28,6 +28,10 @@ pkgbase = yass-proxy
provides = yass-proxy
conflicts = yass-proxy-git
source = https://github.com/Chilledheart/yass/releases/download/1.9.5/yass-1.9.5.tar.bz2
+ source = boringssl-gcc-14.patch
+ source = libcxx-gcc-14.patch
sha256sums = 26e013c811f0b4cb194bfd4587fa6e644b5f155593df0c6a15c026120084a635
+ sha256sums = 6201584f8c5c983405e07f99a83e33a28e1aa907a752bc07bc641d0cf1087662
+ sha256sums = 72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4
pkgname = yass-proxy
diff --git a/PKGBUILD b/PKGBUILD
index d52dda90f662..ae30dd6756e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=yass-proxy
pkgver=1.9.5
-pkgrel=1
+pkgrel=2
_pkgver=1.9.5
_pkgrel=1
pkgdesc="lightweight http/socks proxy"
@@ -16,12 +16,20 @@ makedepends=(git ninja perl pkg-config cmake gtk4 gettext curl go clang lld llvm
checkdepends=(curl)
provides=(yass-proxy)
conflicts=(yass-proxy-git)
-source=("https://github.com/Chilledheart/yass/releases/download/${_pkgver}/yass-${_pkgver}.tar.bz2")
-sha256sums=('26e013c811f0b4cb194bfd4587fa6e644b5f155593df0c6a15c026120084a635')
+source=("https://github.com/Chilledheart/yass/releases/download/${_pkgver}/yass-${_pkgver}.tar.bz2"
+ "boringssl-gcc-14.patch"
+ "libcxx-gcc-14.patch"
+ )
+sha256sums=('26e013c811f0b4cb194bfd4587fa6e644b5f155593df0c6a15c026120084a635'
+ '6201584f8c5c983405e07f99a83e33a28e1aa907a752bc07bc641d0cf1087662'
+ '72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4'
+ )
prepare() {
SRC_DIR="${srcdir}/yass-${_pkgver}"
pushd $SRC_DIR
+ patch --forward --strip=1 --input=../boringssl-gcc-14.patch
+ patch --forward --strip=1 --input=../libcxx-gcc-14.patch
cd tools
go build
cd ..
diff --git a/boringssl-gcc-14.patch b/boringssl-gcc-14.patch
new file mode 100644
index 000000000000..366e21f458d1
--- /dev/null
+++ b/boringssl-gcc-14.patch
@@ -0,0 +1,22 @@
+diff --git a/third_party/boringssl/src/crypto/internal.h b/third_party/boringssl/src/crypto/internal.h
+index 762eaae8c..27652fbe9 100644
+--- a/third_party/boringssl/src/crypto/internal.h
++++ b/third_party/boringssl/src/crypto/internal.h
+@@ -1201,7 +1201,7 @@ static inline uint64_t CRYPTO_rotr_u64(uint64_t value, int shift) {
+
+ // CRYPTO_addc_* returns |x + y + carry|, and sets |*out_carry| to the carry
+ // bit. |carry| must be zero or one.
+-#if OPENSSL_HAS_BUILTIN(__builtin_addc)
++#if OPENSSL_HAS_BUILTIN(__builtin_addc) && !defined(__cplusplus)
+
+ #define CRYPTO_GENERIC_ADDC(x, y, carry, out_carry) \
+ (_Generic((x), \
+@@ -1253,7 +1253,7 @@ static inline uint64_t CRYPTO_addc_u64(uint64_t x, uint64_t y, uint64_t carry,
+
+ // CRYPTO_subc_* returns |x - y - borrow|, and sets |*out_borrow| to the borrow
+ // bit. |borrow| must be zero or one.
+-#if OPENSSL_HAS_BUILTIN(__builtin_subc)
++#if OPENSSL_HAS_BUILTIN(__builtin_subc) && !defined(__cplusplus)
+
+ #define CRYPTO_GENERIC_SUBC(x, y, borrow, out_borrow) \
+ (_Generic((x), \
diff --git a/libcxx-gcc-14.patch b/libcxx-gcc-14.patch
new file mode 100644
index 000000000000..e0fb00c20c87
--- /dev/null
+++ b/libcxx-gcc-14.patch
@@ -0,0 +1,13 @@
+diff --git a/third_party/libc++/trunk/include/__type_traits/remove_pointer.h b/third_party/libc++/trunk/include/__type_traits/remove_pointer.h
+index 54390a193..c01eb3c37 100644
+--- a/third_party/libc++/trunk/include/__type_traits/remove_pointer.h
++++ b/third_party/libc++/trunk/include/__type_traits/remove_pointer.h
+@@ -17,7 +17,7 @@
+
+ _LIBCPP_BEGIN_NAMESPACE_STD
+
+-#if !defined(_LIBCPP_WORKAROUND_OBJCXX_COMPILER_INTRINSICS) && __has_builtin(__remove_pointer)
++#if !defined(_LIBCPP_WORKAROUND_OBJCXX_COMPILER_INTRINSICS) && __has_builtin(__remove_pointer) && !defined(_LIBCPP_GCC_VER)
+ template <class _Tp>
+ struct remove_pointer {
+ using type _LIBCPP_NODEBUG = __remove_pointer(_Tp);