summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeeyou2024-06-11 11:45:15 +0800
committerKeeyou2024-06-11 11:45:15 +0800
commitd205a36edcef07bafaa775f80eff1d62880ff0b9 (patch)
tree1f771c4868ea553e5ffadda085dd48aacecf20b6
parent943c74cf5a5d637e352e314c879e7dd7a7db2d10 (diff)
downloadaur-d205a36edcef07bafaa775f80eff1d62880ff0b9.tar.gz
update for 1.11.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--libcxx-gcc-14.patch13
3 files changed, 8 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd868a751c4a..b60e57a65345 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yass-proxy
pkgdesc = lightweight http/socks proxy
- pkgver = 1.10.5
- pkgrel = 2
+ pkgver = 1.11.0
+ pkgrel = 1
url = https://github.com/Chilledheart/yass
arch = x86_64
license = GPL-2.0-only
@@ -28,9 +28,7 @@ pkgbase = yass-proxy
conflicts = yass-proxy-git
conflicts = yass-proxy-qt6
conflicts = yass-proxy-gtk3
- source = https://github.com/Chilledheart/yass/releases/download/1.10.5/yass-1.10.5.tar.bz2
- source = libcxx-gcc-14.patch
- sha256sums = 0b94788d253a4437fa632ddcce4dd283537934eb036b590bb2691ad8824c408d
- sha256sums = 72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4
+ source = https://github.com/Chilledheart/yass/releases/download/1.11.0/yass-1.11.0.tar.bz2
+ sha256sums = 860dcf98328d4988647abc2c9c79ff8b2346e1bc95dffe891a0f9fdfa1891fab
pkgname = yass-proxy
diff --git a/PKGBUILD b/PKGBUILD
index e8031ccec138..6c6dede81c45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Keeyou <keeyou-cn@outlook.com>
pkgname=yass-proxy
-pkgver=1.10.5
-pkgrel=2
-_pkgver=1.10.5
+pkgver=1.11.0
+pkgrel=1
+_pkgver=1.11.0
_pkgrel=1
pkgdesc="lightweight http/socks proxy"
arch=(x86_64)
@@ -17,16 +17,12 @@ checkdepends=(curl)
provides=(yass-proxy)
conflicts=(yass-proxy-git yass-proxy-qt6 yass-proxy-gtk3)
source=("https://github.com/Chilledheart/yass/releases/download/${_pkgver}/yass-${_pkgver}.tar.bz2"
- "libcxx-gcc-14.patch"
)
-sha256sums=('0b94788d253a4437fa632ddcce4dd283537934eb036b590bb2691ad8824c408d'
- '72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4'
- )
+sha256sums=('860dcf98328d4988647abc2c9c79ff8b2346e1bc95dffe891a0f9fdfa1891fab')
prepare() {
SRC_DIR="${srcdir}/yass-${_pkgver}"
pushd $SRC_DIR
- patch --forward --strip=1 --input=../libcxx-gcc-14.patch
cd tools
go build
cd ..
diff --git a/libcxx-gcc-14.patch b/libcxx-gcc-14.patch
deleted file mode 100644
index e0fb00c20c87..000000000000
--- a/libcxx-gcc-14.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/third_party/libc++/trunk/include/__type_traits/remove_pointer.h b/third_party/libc++/trunk/include/__type_traits/remove_pointer.h
-index 54390a193..c01eb3c37 100644
---- a/third_party/libc++/trunk/include/__type_traits/remove_pointer.h
-+++ b/third_party/libc++/trunk/include/__type_traits/remove_pointer.h
-@@ -17,7 +17,7 @@
-
- _LIBCPP_BEGIN_NAMESPACE_STD
-
--#if !defined(_LIBCPP_WORKAROUND_OBJCXX_COMPILER_INTRINSICS) && __has_builtin(__remove_pointer)
-+#if !defined(_LIBCPP_WORKAROUND_OBJCXX_COMPILER_INTRINSICS) && __has_builtin(__remove_pointer) && !defined(_LIBCPP_GCC_VER)
- template <class _Tp>
- struct remove_pointer {
- using type _LIBCPP_NODEBUG = __remove_pointer(_Tp);