summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeeyou2024-06-03 12:57:04 +0800
committerKeeyou2024-06-03 13:04:32 +0800
commite134af1425cf0990fcb2cd90b497d039ed8cc4b0 (patch)
treee05cd72f3c4f9c5911a86c181ad0e748923b23e0
parent470c1c5858e2b3e279773275d08b25d5cb43b1b5 (diff)
downloadaur-e134af1425cf0990fcb2cd90b497d039ed8cc4b0.tar.gz
update for 1.10.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f6adc2592c7..d97a994b511b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yass-proxy
pkgdesc = lightweight http/socks proxy
- pkgver = 1.10.4
+ pkgver = 1.10.5
pkgrel = 1
url = https://github.com/Chilledheart/yass
arch = x86_64
@@ -18,18 +18,22 @@ pkgbase = yass-proxy
makedepends = clang
makedepends = lld
makedepends = llvm
+ makedepends = gperftools
depends = gcc-libs
depends = glibc
depends = gtk4
depends = zlib
depends = libnghttp2
depends = c-ares
+ depends = gperftools
optdepends = gtk-update-icon-cache
provides = yass-proxy
conflicts = yass-proxy-git
- source = https://github.com/Chilledheart/yass/releases/download/1.10.4/yass-1.10.4.tar.bz2
+ conflicts = yass-proxy-qt6
+ conflicts = yass-proxy-gtk3
+ source = https://github.com/Chilledheart/yass/releases/download/1.10.5/yass-1.10.5.tar.bz2
source = libcxx-gcc-14.patch
- sha256sums = f4beadf9dfb3cd506426909fb1a03fcd5e6151658e9decaf0fe3734bd78c0cbb
+ sha256sums = 0b94788d253a4437fa632ddcce4dd283537934eb036b590bb2691ad8824c408d
sha256sums = 72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4
pkgname = yass-proxy
diff --git a/PKGBUILD b/PKGBUILD
index 20261361a3fe..b2be7f8c10d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Chilledheart <hukeyue@hotmail.com>
-# Contributor: Chilledheart <hukeyue@hotmail.com>
+# Maintainer: Keeyou <keeyou-cn@outlook.com>
+# Contributor: Keeyou <keeyou-cn@outlook.com>
pkgname=yass-proxy
-pkgver=1.10.4
+pkgver=1.10.5
pkgrel=1
-_pkgver=1.10.4
+_pkgver=1.10.5
_pkgrel=1
pkgdesc="lightweight http/socks proxy"
arch=(x86_64)
url="https://github.com/Chilledheart/yass"
license=(GPL-2.0-only)
-depends=(gcc-libs glibc gtk4 zlib libnghttp2 c-ares)
+depends=(gcc-libs glibc gtk4 zlib libnghttp2 c-ares gperftools)
optdepends=(gtk-update-icon-cache)
-makedepends=(git ninja perl pkg-config cmake gtk4 gettext curl go clang lld llvm)
+makedepends=(git ninja perl pkg-config cmake gtk4 gettext curl go clang lld llvm gperftools)
checkdepends=(curl)
provides=(yass-proxy)
-conflicts=(yass-proxy-git)
+conflicts=(yass-proxy-git yass-proxy-qt6 yass-proxy-gtk3)
source=("https://github.com/Chilledheart/yass/releases/download/${_pkgver}/yass-${_pkgver}.tar.bz2"
"libcxx-gcc-14.patch"
)
-sha256sums=('f4beadf9dfb3cd506426909fb1a03fcd5e6151658e9decaf0fe3734bd78c0cbb'
+sha256sums=('0b94788d253a4437fa632ddcce4dd283537934eb036b590bb2691ad8824c408d'
'72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4'
)
@@ -41,10 +41,12 @@ build(){
rm -rf build-linux-amd64
mkdir build-linux-amd64
cd build-linux-amd64
- cmake .. -DGUI=ON -DCMAKE_BUILD_TYPE=Release -G Ninja -DBUILD_TESTS=on \
+ cmake .. -DCMAKE_BUILD_TYPE=Release -G Ninja -DBUILD_TESTS=on \
+ -DUSE_TCMALLOC=on -DUSE_SYSTEM_TCMALLOC=on \
-DUSE_SYSTEM_ZLIB=on -DUSE_SYSTEM_CARES=on -DUSE_SYSTEM_NGHTTP2=on \
- -DCMAKE_INSTALL_PREFIX=/usr -DCLI=off -DSERVER=off \
- -DUSE_LIBCXX=on -DENABLE_LTO=on -DUSE_TCMALLOC=on
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGUI=ON -DUSE_GTK4=on -DCLI=off -DSERVER=off \
+ -DUSE_LIBCXX=off -DENABLE_LTO=on
ninja yass yass_test
llvm-objcopy --strip-debug yass
cd ..