diff options
author | Keeyou | 2024-05-11 11:02:27 +0800 |
---|---|---|
committer | Keeyou | 2024-05-11 11:02:40 +0800 |
commit | c20c090ca5aeb1bd76e125e9f15f87f9c180be7a (patch) | |
tree | b1530f2d5b25cc5e8922bb190163e5c31ac25cfc | |
parent | d5e4a3054383199d7a4528ec3be0fd88a0322e46 (diff) | |
download | aur-c20c090ca5aeb1bd76e125e9f15f87f9c180be7a.tar.gz |
update for 1.9.5-r3
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 5 | ||||
-rw-r--r-- | cmake.patch | 29 |
3 files changed, 36 insertions, 2 deletions
@@ -1,7 +1,7 @@ pkgbase = yass-proxy-cli pkgdesc = lightweight http/socks proxy commandline pkgver = 1.9.5 - pkgrel = 2 + pkgrel = 3 url = https://github.com/Chilledheart/yass arch = x86_64 license = GPL-2.0-only @@ -27,8 +27,10 @@ pkgbase = yass-proxy-cli source = https://github.com/Chilledheart/yass/releases/download/1.9.5/yass-1.9.5.tar.bz2 source = boringssl-gcc-14.patch source = libcxx-gcc-14.patch + source = cmake.patch sha256sums = 26e013c811f0b4cb194bfd4587fa6e644b5f155593df0c6a15c026120084a635 sha256sums = 6201584f8c5c983405e07f99a83e33a28e1aa907a752bc07bc641d0cf1087662 sha256sums = 72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4 + sha256sums = 24cef2470a32381e771ce110e5bae4f1f96e589e9d59a3aa6c294ba5cf6a8d71 pkgname = yass-proxy-cli @@ -3,7 +3,7 @@ pkgname=yass-proxy-cli pkgver=1.9.5 -pkgrel=2 +pkgrel=3 _pkgver=1.9.5 _pkgrel=1 pkgdesc="lightweight http/socks proxy commandline" @@ -18,10 +18,12 @@ conflicts=(yass-proxy-cli-git) source=("https://github.com/Chilledheart/yass/releases/download/${_pkgver}/yass-${_pkgver}.tar.bz2" "boringssl-gcc-14.patch" "libcxx-gcc-14.patch" + "cmake.patch" ) sha256sums=('26e013c811f0b4cb194bfd4587fa6e644b5f155593df0c6a15c026120084a635' '6201584f8c5c983405e07f99a83e33a28e1aa907a752bc07bc641d0cf1087662' '72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4' + '24cef2470a32381e771ce110e5bae4f1f96e589e9d59a3aa6c294ba5cf6a8d71' ) prepare() { @@ -29,6 +31,7 @@ prepare() { pushd $SRC_DIR patch --forward --strip=1 --input=../boringssl-gcc-14.patch patch --forward --strip=1 --input=../libcxx-gcc-14.patch + patch --forward --strip=1 --input=../cmake.patch cd tools go build cd .. diff --git a/cmake.patch b/cmake.patch new file mode 100644 index 000000000000..9afd461a6cac --- /dev/null +++ b/cmake.patch @@ -0,0 +1,29 @@ +commit dabb3237db4112abde0020cbb0b6a80f477e6aee +Author: Keeyou <keeyou-cn@outlook.com> +Date: Sat May 11 10:55:46 2024 +0800 + + gperftools: set benchmark to off (trivial) + +diff --git a/CMakeLists.txt b/CMakeLists.txt +index a36248d9..98942410 100644 +--- a/CMakeLists.txt ++++ b/CMakeLists.txt +@@ -2411,12 +2411,12 @@ if (USE_SYSTEM_TCMALLOC AND USE_TCMALLOC) + elseif (USE_TCMALLOC) + message(STATUS "Compiling with bundled tcmalloc support") + +- set(GPERFTOOLS_BUILD_DEBUGALLOC OFF) +- set(gperftools_build_minimal ON) +- set(gperftools_build_benchmark OFF) +- set(GPERFTOOLS_BUILD_STATIC ON) +- set(GPERFTOOLS_ENABLE_INSTALL OFF) +- set(GPERFTOOLS_BUILD_TESTING OFF) ++ set(GPERFTOOLS_BUILD_DEBUGALLOC OFF CACHE BOOL "") ++ set(gperftools_build_minimal ON CACHE BOOL "") ++ set(gperftools_build_benchmark OFF CACHE BOOL "") ++ set(GPERFTOOLS_BUILD_STATIC ON CACHE BOOL "") ++ set(GPERFTOOLS_ENABLE_INSTALL OFF CACHE BOOL "") ++ set(GPERFTOOLS_BUILD_TESTING OFF CACHE BOOL "") + add_subdirectory(third_party/gperftools) + + set_target_properties(tcmalloc_minimal PROPERTIES EXCLUDE_FROM_ALL TRUE) |