summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeeyou2024-07-29 09:25:27 +0800
committerKeeyou2024-07-29 09:28:37 +0800
commit7a54065633953fc27673ae117b14fd9d249cb6db (patch)
tree964bd366e16e598bdec8a7eaf91a945d05f2fdd0
parent07b6a4c433b0bdeb2dd26ab367fab580a5af6891 (diff)
downloadaur-7a54065633953fc27673ae117b14fd9d249cb6db.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD66
2 files changed, 45 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b35b529d468..4bc9fbd9cdf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,32 @@
pkgbase = yass-proxy-git
pkgdesc = lightweight http/socks proxy
- pkgver = 1.4.0.r102.gdcd3d26
+ pkgver = 1.12.1.r1.g6d8bf7d6
pkgrel = 1
url = https://github.com/Chilledheart/yass
arch = i686
arch = x86_64
license = GPL 2.0
checkdepends = curl
+ makedepends = gcc
+ makedepends = binutils
makedepends = git
makedepends = ninja
makedepends = perl
makedepends = pkg-config
makedepends = cmake
- makedepends = gtk4
makedepends = gettext
makedepends = curl
makedepends = go
depends = gcc-libs
depends = glibc
- depends = gtk4
+ depends = gtk3
+ depends = zlib
+ depends = libnghttp2
+ depends = c-ares
+ depends = gperftools
optdepends = gtk-update-icon-cache
+ optdepends = libappindicator-gtk3
+ optdepends = libayatana-appindicator
provides = yass-proxy
conflicts = yass-proxy
source = git+https://github.com/Chilledheart/yass.git
diff --git a/PKGBUILD b/PKGBUILD
index d944466045d9..c98ef556c797 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,60 +2,64 @@
# Contributor: Chilledheart <hukeyue@hotmail.com>
pkgname=yass-proxy-git
-pkgver=1.4.0.r102.gdcd3d26
+pkgver=1.12.1.r1.g6d8bf7d6
pkgrel=1
pkgdesc="lightweight http/socks proxy"
arch=(i686 x86_64)
url="https://github.com/Chilledheart/yass"
license=('GPL 2.0')
-depends=(gcc-libs glibc gtk4)
-optdepends=(gtk-update-icon-cache)
-makedepends=(git ninja perl pkg-config cmake gtk4 gettext curl go)
-checkdepends=("curl")
+depends=(gcc-libs glibc gtk3 zlib libnghttp2 c-ares gperftools)
+optdepends=(gtk-update-icon-cache libappindicator-gtk3 libayatana-appindicator)
+makedepends=(gcc binutils git ninja perl pkg-config cmake gettext curl go)
+checkdepends=(curl)
provides=(yass-proxy)
conflicts=(yass-proxy)
source=("git+https://github.com/Chilledheart/yass.git")
sha256sums=('SKIP')
prepare() {
- cd yass
+ SRC_DIR="${srcdir}/yass"
+ cd "$SRC_DIR"
git submodule update --init
- ./scripts/download-clang-prebuilt-binaries.py
- cd tools
- go build
- cd ..
}
pkgver() {
- cd yass
+ SRC_DIR="${srcdir}/yass"
+ cd "$SRC_DIR"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build(){
- cd yass
- export CC=$PWD/third_party/llvm-build/Release+Asserts/bin/clang
- export CXX=$PWD/third_party/llvm-build/Release+Asserts/bin/clang++
- ./tools/build --variant gui --system linux -build-test
+ SRC_DIR="${srcdir}/yass"
+ pushd $SRC_DIR
+ rm -rf build
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -G Ninja -DBUILD_TESTS=on \
+ -DUSE_TCMALLOC=on -DUSE_SYSTEM_TCMALLOC=on \
+ -DUSE_SYSTEM_ZLIB=on -DUSE_SYSTEM_CARES=on -DUSE_SYSTEM_NGHTTP2=on \
+ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DGUI=ON -DUSE_GTK4=off -DCLI=off -DSERVER=off
+ ninja yass yass_test
+ cd ..
+
+ popd
}
check() {
- cd yass
- ./build-linux-amd64/yass_test
+ SRC_DIR="${srcdir}/yass"
+ pushd $SRC_DIR
+ ./build/yass_test
+ popd
}
package(){
- cd yass
-
- install -Dm755 build-linux-amd64/yass ${pkgdir}/usr/bin/yass
- install -Dm644 build-linux-amd64/LICENSE ${pkgdir}/usr/share/licenses/yass/LICENSE
-
- install -Dm644 src/gtk/yass.desktop ${pkgdir}/usr/share/applications/yass.desktop
- install -Dm644 src/gtk/icons/16x16/apps/yass.png ${pkgdir}/usr/share/icons/hicolor/16x16/apps/yass.png
- install -Dm644 src/gtk/icons/22x22/apps/yass.png ${pkgdir}/usr/share/icons/hicolor/22x22/apps/yass.png
- install -Dm644 src/gtk/icons/24x24/apps/yass.png ${pkgdir}/usr/share/icons/hicolor/24x24/apps/yass.png
- install -Dm644 src/gtk/icons/32x32/apps/yass.png ${pkgdir}/usr/share/icons/hicolor/32x32/apps/yass.png
- install -Dm644 src/gtk/icons/48x48/apps/yass.png ${pkgdir}/usr/share/icons/hicolor/48x48/apps/yass.png
- install -Dm644 src/gtk/icons/128x128/apps/yass.png ${pkgdir}/usr/share/icons/hicolor/128x128/apps/yass.png
- install -Dm644 src/gtk/icons/256x256/apps/yass.png ${pkgdir}/usr/share/icons/hicolor/256x256/apps/yass.png
- install -Dm644 src/gtk/icons/512x512/apps/yass.png ${pkgdir}/usr/share/icons/hicolor/512x512/apps/yass.png
+ SRC_DIR="${srcdir}/yass"
+ pushd $SRC_DIR
+
+ install -Dm644 ./build/LICENSE ${pkgdir}/usr/share/licenses/yass/LICENSE
+ DESTDIR=${pkgdir} ninja -C build install
+ rm -rf ${pkgdir}/usr/share/doc
+
+ popd
}