summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-13 13:49:13 +0300
committerDimitris Kiziridis2020-07-13 13:49:13 +0300
commit6fe38fd09666fb02960d7e1140d57e1c2a477377 (patch)
treedd1315b83a3ad7e580f2584d835610a38ffc701d
downloadaur-6fe38fd09666fb02960d7e1140d57e1c2a477377.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f61316a387bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = yasw
+ pkgdesc = An application used to correct images taken with a camera
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://sourceforge.net/projects/yascanw
+ arch = x86_64
+ license = GPL3
+ makedepends = qt4
+ makedepends = doxygen
+ depends = qt4
+ source = yasw-0.5.tgz::https://sourceforge.net/projects/yascanw/files/YASW%200.5/yasw_0.5.tgz/download
+ sha256sums = a5c6eb08e3ed14d96da89b16c79dcb2d19e2344696b09b3b2f2f3addc98ca65b
+
+pkgname = yasw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a10497f971c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=yasw
+pkgver=0.5
+pkgrel=1
+pkgdesc="An application used to correct images taken with a camera"
+arch=('x86_64')
+url="https://sourceforge.net/projects/yascanw"
+license=('GPL3')
+depends=('qt4')
+makedepends=('qt4' 'doxygen')
+source=("${pkgname}-${pkgver}.tgz::https://sourceforge.net/projects/yascanw/files/YASW%20${pkgver}/yasw_${pkgver}.tgz/download")
+sha256sums=('a5c6eb08e3ed14d96da89b16c79dcb2d19e2344696b09b3b2f2f3addc98ca65b')
+
+ build() {
+ cd "${pkgname}_${pkgver}/src"
+ # rm -rf build
+ mkdir -p build
+ cd build
+ qmake-qt4 PREFIX=/usr ..
+ make
+ cd ../../documentation
+ make
+}
+
+package() {
+ cd "${pkgname}_${pkgver}/src/build"
+ install -Dm755 yasw "${pkgdir}/usr/bin/yasw"
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -aR ../../documentation/doxygen/html/ "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 ../../changelog.txt -t "${pkgdir}/usr/share/doc/${pkgname}"
+} \ No newline at end of file