summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdelin-b2020-06-07 12:03:26 +0000
committerAdelin-b2020-06-07 12:03:26 +0000
commite4cceeac7632484fe82f051995d8ead736df2290 (patch)
tree6a5f4ae282df96995384a6a19af347228f167057
downloadaur-e4cceeac7632484fe82f051995d8ead736df2290.tar.gz
Update AUR package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea15cfa743ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yawhich-key-git
+ pkgdesc = Yet another which-key but universal for all applications, desktop environment
+ pkgver = 0.7.0.r4.gc732ab9
+ pkgrel = 1
+ url = https://github.com/adelin-b/yawhich-key
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = rofi
+ depends = yq2-bin
+ provides = yawhich-key
+ conflicts = yawhich-key
+ source = yawhich-key-git-0.7.0.r4.gc732ab9::git+https://github.com/adelin-b/yawhich-key.git
+ md5sums = SKIP
+
+pkgname = yawhich-key-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a57a32f599c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: adelin-b
+pkgname=('yawhich-key-git')
+pkgrel=1
+pkgver=0.7.0.r4.gc732ab9
+pkgdesc="Yet another which-key but universal for all applications, desktop environment"
+arch=('any')
+url="https://github.com/adelin-b/yawhich-key"
+license=('GPL3')
+# groups=()
+depends=('rofi'
+ 'yq2-bin')
+makedepends=('git')
+# optdepends=()
+# replaces=()
+provides=("yawhich-key")
+conflicts=("yawhich-key")
+# backup=()
+# options=()
+# install=
+# changelog=$pkgname
+source=("$pkgname-$pkgver::git+https://github.com/adelin-b/yawhich-key.git")
+
+# noextract=()
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ echo $srcdir
+ pwd
+ echo $DESTDIR
+ echo $pkgdir
+ make DESTDIR="$pkgdir/" install
+ # install -Dm744 "${srcdir}/yawhich-key" "${pkgdir}/urs/local/bin/yawhich-key}"
+
+}
+
+pkgver() {
+ cd "$srcdir/$_name"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+