summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjguer2021-05-20 13:42:11 +0200
committerjguer2021-05-20 13:42:11 +0200
commit773d0d0dff4926fd4a6ef7969779b30f5bca4b57 (patch)
tree719a5129f47177a0168e3887011d7e0e94d8eb3f
parentbd7006c9db8be31f07540a854558299f2c795a57 (diff)
downloadaur-773d0d0dff4926fd4a6ef7969779b30f5bca4b57.tar.gz
upgpkg: yay 10.2.2-2
add warning
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 106eda1546cb..b315da53c0d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yay
pkgdesc = Yet another yogurt. Pacman wrapper and AUR helper written in go.
pkgver = 10.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Jguer/yay
arch = i686
arch = pentium4
diff --git a/PKGBUILD b/PKGBUILD
index 50ec63cb8501..95a46649537e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jguer <joaogg3@gmail.com>
pkgname=yay
pkgver=10.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Yet another yogurt. Pacman wrapper and AUR helper written in go."
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/Jguer/yay"
@@ -19,6 +19,11 @@ makedepends=(
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Jguer/yay/archive/v${pkgver}.tar.gz")
sha256sums=('0e3fc11d6a26056d02db5aae863ca7b874578a94fe5c1250272a3bca376a24e2')
+# With pacman 6 arriving a rebuild of yay will be necessary, if you upgrade pacman without upgrading yay at the same time, yay will not run after.
+# I'm bumping the pkgrel so it shows up on the upgrade list (and will do so when pacman transitions from staging->core)
+# In case you end up with a non-functioning yay after the upgrade follow the
+# instructions on the github page
+
build() {
export GOPATH="$srcdir"/gopath
export CGO_CPPFLAGS="${CPPFLAGS}"