summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-02-06 19:20:12 +0100
committerMichael Straube2017-02-06 19:56:26 +0100
commit7fb48e33c41439a8aed07e900de3f46e9e07da57 (patch)
tree1ab1435809f79a30d7c7d9d589555d05003a1e1f
parenta6d08511d0c4c27bcdba9fafedcade6cf523ea39 (diff)
downloadaur-7fb48e33c41439a8aed07e900de3f46e9e07da57.tar.gz
Update to 2.40.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
-rw-r--r--yaze.patch81
3 files changed, 48 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f93b088efdb..8adaf56fc890 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = yaze
pkgdesc = Yet Another z80 (CP/M) Emulator
- pkgver = 2.30.3
+ pkgver = 2.40.3
pkgrel = 1
url = http://www.mathematik.uni-ulm.de/users/ag/yaze-ag/
- arch = i386
+ arch = i686
arch = x86_64
license = GPL
- source = http://www.mathematik.uni-ulm.de/users/ag/yaze-ag/devel/yaze-ag-2.30.3.tar.gz
+ source = http://www.mathematik.uni-ulm.de/users/ag/yaze-ag/devel/yaze-ag-2.40.3_with_keytrans.tar.gz
source = yaze.patch
- sha1sums = f3c162053bb25035cabe5da55a08efa94322fe95
- sha1sums = f9a4f8c9500746fd2a470c6f6826b0744e8f414f
+ sha256sums = ae1899527ae45cec073dd4a7922ed967514d8cf77dfde9a612b41916535ac310
+ sha256sums = c0abd301728f95ccd825e3f17c56a743307c219a5fd046782105e65d552e6056
pkgname = yaze
diff --git a/PKGBUILD b/PKGBUILD
index 6d715e4451eb..c69051aa08f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,34 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=yaze
-pkgver=2.30.3
+pkgver=2.40.3
pkgrel=1
license=('GPL')
pkgdesc='Yet Another z80 (CP/M) Emulator'
-arch=("i386" "x86_64")
+arch=("i686" "x86_64")
url='http://www.mathematik.uni-ulm.de/users/ag/yaze-ag/'
-source=("http://www.mathematik.uni-ulm.de/users/ag/yaze-ag/devel/yaze-ag-2.30.3.tar.gz"
- "yaze.patch")
-sha1sums=('f3c162053bb25035cabe5da55a08efa94322fe95'
- 'f9a4f8c9500746fd2a470c6f6826b0744e8f414f')
+source=("http://www.mathematik.uni-ulm.de/users/ag/yaze-ag/devel/yaze-ag-${pkgver}_with_keytrans.tar.gz"
+ "yaze.patch")
+sha256sums=('ae1899527ae45cec073dd4a7922ed967514d8cf77dfde9a612b41916535ac310'
+ 'c0abd301728f95ccd825e3f17c56a743307c219a5fd046782105e65d552e6056')
prepare() {
- cd "${srcdir}/${pkgname}-ag-${pkgver}"
+ cd ${pkgname}-ag-${pkgver}_with_keytrans
- patch -p1 -i $srcdir/yaze.patch
+ patch -p1 -i ../yaze.patch
+ cp Makefile_linux_32_i586 Makefile
}
build() {
- cd "${srcdir}/${pkgname}-ag-${pkgver}"
+ cd ${pkgname}-ag-${pkgver}_with_keytrans
- make -f Makefile_linux
+ [[ ${CARCH} == x86_64 ]] && _BUILD='" (build for x86_64Bit (x86-64))"'
+ [[ ${CARCH} == i686 ]] && _BUILD='" (build for x86_32Bit (i686))"'
+
+ make PREFIX=/usr BUILD="${_BUILD}" OPTIMIZE="${CFLAGS/-O2/-O3}"
}
package() {
- cd "${srcdir}/${pkgname}-ag-${pkgver}"
+ cd ${pkgname}-ag-${pkgver}_with_keytrans
- make PREFIX="$pkgdir/usr" -f Makefile_linux install
+ make PREFIX="${pkgdir}/usr" install
}
diff --git a/yaze.patch b/yaze.patch
index 096fe46a6165..42a494b581e9 100644
--- a/yaze.patch
+++ b/yaze.patch
@@ -1,36 +1,20 @@
-diff -aur yaze-ag-2.30.3-pristine/Makefile_linux yaze-ag-2.30.3-patched/Makefile_linux
---- yaze-ag-2.30.3-pristine/Makefile_linux 2015-01-06 19:13:11.951033955 -0700
-+++ yaze-ag-2.30.3-patched/Makefile_linux 2015-01-06 19:13:20.224274093 -0700
-@@ -4,12 +4,13 @@
+diff -ur yaze-ag-2.40.3_with_keytrans-orig/Makefile_linux_32_i586 yaze-ag-2.40.3_with_keytrans/Makefile_linux_32_i586
+--- yaze-ag-2.40.3_with_keytrans-orig/Makefile_linux_32_i586 2017-02-06 18:45:40.186909802 +0100
++++ yaze-ag-2.40.3_with_keytrans/Makefile_linux_32_i586 2017-02-06 19:01:49.772906822 +0100
+@@ -6,9 +6,9 @@
CC = gcc
#where you want the binaries and manual page
-BINDIR = /usr/local/bin
-MANDIR = /usr/local/man/man1
-LIBDIR = /usr/local/lib/yaze
--DSKDIR = $(LIBDIR)/disks
--DOCDIR = $(LIBDIR)/doc
--DOCHTMLDIR = $(LIBDIR)/doc_html
-+PREFIX := /usr/local
-+BINDIR = $(PREFIX)/bin/
-+MANDIR = $(PREFIX)/man/man1/
-+LIBDIR = $(PREFIX)/lib/yaze/
-+DSKDIR = $(LIBDIR)/disks/
-+DOCDIR = $(LIBDIR)/doc/
-+DOCHTMLDIR = $(LIBDIR)/doc_html/
-
- #OPTIMIZE = -g -m486
- #OPTIMIZE = -g -save-temps -m486
-@@ -44,7 +45,7 @@
- #OPTIMIZE = -O3 -march=pentiumpro
- #OPTIMIZE = -O3 -march=pentium2
- #OPTIMIZE = -O3 -march=pentium3
--OPTIMIZE = -O3 -march=pentium4
-+OPTIMIZE = -O3
- #OPTIMIZE = -O3 -march=nocona # 64 Bit Intel
- #OPTIMIZE = -O3 -march=k6
- #OPTIMIZE = -O3 -march=k6-2
-@@ -180,6 +181,7 @@
++BINDIR = $(PREFIX)/bin
++MANDIR = $(PREFIX)/share/man/man1
++LIBDIR = $(PREFIX)/lib/yaze
+ DSKDIR = $(LIBDIR)/disks
+ DOCDIR = $(LIBDIR)/doc
+ DOCHTMLDIR = $(LIBDIR)/doc_html
+@@ -205,11 +205,12 @@
rm -rf $(LIBDIR)
mkdir -p $(LIBDIR)
mkdir -p $(MANDIR)
@@ -38,9 +22,16 @@ diff -aur yaze-ag-2.30.3-pristine/Makefile_linux yaze-ag-2.30.3-patched/Makefile
$(INSTALL) -s -c -m 755 yaze_bin $(BINDIR)
$(INSTALL) -s -c -m 755 cdm $(BINDIR)
$(INSTALL) -c -m 755 yaze $(BINDIR)
-diff -aur yaze-ag-2.30.3-pristine/yaze.1 yaze-ag-2.30.3-patched/yaze.1
---- yaze-ag-2.30.3-pristine/yaze.1 2015-01-06 19:13:11.951033955 -0700
-+++ yaze-ag-2.30.3-patched/yaze.1 2015-01-06 19:13:20.224274093 -0700
+- ln -f -s $(BINDIR)/yaze $(BINDIR)/cpm
+- ln -f -s $(BINDIR)/yaze $(BINDIR)/z80
++ ln -f -s /usr/bin/yaze $(BINDIR)/cpm
++ ln -f -s /usr/bin/yaze $(BINDIR)/z80
+ $(INSTALL) -c -m 644 yaze-cpm3.boot $(LIBDIR)
+ $(INSTALL) -c -m 644 yaze.boot $(LIBDIR)
+ $(INSTALL) -c -m 644 m2.ktt $(LIBDIR)
+diff -ur yaze-ag-2.40.3_with_keytrans-orig/yaze.1 yaze-ag-2.40.3_with_keytrans/yaze.1
+--- yaze-ag-2.40.3_with_keytrans-orig/yaze.1 2017-02-06 18:45:40.196909589 +0100
++++ yaze-ag-2.40.3_with_keytrans/yaze.1 2017-02-06 19:01:49.776240084 +0100
@@ -91,7 +91,7 @@
address given by the \fB-l\fR option, if one is present, or else at
the basepage (see \fB-p\fR). If a bootfile is not specified with the
@@ -50,35 +41,17 @@ diff -aur yaze-ag-2.30.3-pristine/yaze.1 yaze-ag-2.30.3-patched/yaze.1
If yaze-ag is compiled without the flag -DBOOTSYS yaze-ag looks for the
file yaze.boot (instead of yaze-cpm3.boot) to boot the CP/M 2.2 replacement
SuperDos.
-diff -aur yaze-ag-2.30.3-pristine/yaze.c yaze-ag-2.30.3-patched/yaze.c
---- yaze-ag-2.30.3-pristine/yaze.c 2015-01-06 19:13:11.951033955 -0700
-+++ yaze-ag-2.30.3-patched/yaze.c 2015-01-06 19:13:57.160524934 -0700
-@@ -43,13 +43,13 @@
- /* See definitions for memory in mem_mmu.[c,h] (agl) */
-
- #ifndef LIBDIR
--#define LIBDIR "/usr/local/lib/yaze"
-+#define LIBDIR "/usr/lib/yaze"
- #endif
-
- #ifdef BOOTSYS
--static char *bootfile = "yaze-cpm3.boot";
-+static char *bootfile = "/usr/lib/yaze/yaze-cpm3.boot";
- #else
--static char *bootfile = "yaze.boot";
-+static char *bootfile = "/usr/lib/yaze/yaze.boot";
- #endif
- static char *startup = ".yazerc";
- static char *progname;
-diff -aur yaze-ag-2.30.3-pristine/yaze.sh yaze-ag-2.30.3-patched/yaze.sh
---- yaze-ag-2.30.3-pristine/yaze.sh 2015-01-06 19:13:11.954367250 -0700
-+++ yaze-ag-2.30.3-patched/yaze.sh 2015-01-06 19:13:20.224274093 -0700
-@@ -1,8 +1,8 @@
+diff -ur yaze-ag-2.40.3_with_keytrans-orig/yaze.sh yaze-ag-2.40.3_with_keytrans/yaze.sh
+--- yaze-ag-2.40.3_with_keytrans-orig/yaze.sh 2017-02-06 18:45:40.216909162 +0100
++++ yaze-ag-2.40.3_with_keytrans/yaze.sh 2017-02-06 19:01:49.776240084 +0100
+@@ -1,9 +1,9 @@
#!/bin/sh
+-S_YAZEFILES=/usr/local/lib/yaze
-S_CPMDSKS=/usr/local/lib/yaze/disks
-S_DOCFILES=/usr/local/lib/yaze/doc
-S_DOCFILES_html=/usr/local/lib/yaze/doc_html
++S_YAZEFILES=/usr/lib/yaze
+S_CPMDSKS=/usr/lib/yaze/disks
+S_DOCFILES=/usr/lib/yaze/doc
+S_DOCFILES_html=/usr/lib/yaze/doc_html