summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2019-11-07 11:49:03 +0100
committerRicardo (XenGi) Band2019-11-07 11:49:03 +0100
commitfcd83acd97782bd8818cf7fd0b72b501ecbe18c1 (patch)
tree3f7e89d6e1b32d3cb5d41da088224b67075c31a5
downloadaur-fcd83acd97782bd8818cf7fd0b72b501ecbe18c1.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD29
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..762764a7d686
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ycat
+ pkgdesc = Print yaml files with color (powered by goccy/go-yaml)
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://github.com/goccy/go-yaml
+ arch = any
+ license = MIT
+ makedepends = go-pie
+ source = https://github.com/goccy/go-yaml/archive/v1.0.6.tar.gz
+ sha256sums = 79c4608e2826cb4c8dd1dba50494a76f330e4b47fce598668690dfa61dfb7779
+
+pkgname = ycat
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ccdadf693590
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5baac265c704
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ricardo (XenGi) Band <email@ricardo.band>
+pkgname=ycat
+_pkgname=go-yaml
+pkgver=1.0.6
+pkgrel=1
+pkgdesc='Print yaml files with color (powered by goccy/go-yaml)'
+arch=('any')
+url="https://github.com/goccy/go-yaml"
+license=('MIT')
+makedepends=('go-pie')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('79c4608e2826cb4c8dd1dba50494a76f330e4b47fce598668690dfa61dfb7779')
+
+build() {
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-trimpath"
+ cd $_pkgname-$pkgver/cmd/$pkgname
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname \
+ .
+}
+
+package() {
+ cd $_pkgname-$pkgver/cmd/$pkgname
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}
+