summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad1962024-03-28 09:14:42 +0200
committervlad1962024-03-28 09:14:42 +0200
commit3fddfecca4410d1bc11a6d1a9982dff7bb1531e2 (patch)
tree9e7a407d26ae7110295f392235116de3c820f267
parent3837b7af6c5ed48afafd8bf1ce217ba32f81f54f (diff)
downloadaur-3fddfecca4410d1bc11a6d1a9982dff7bb1531e2.tar.gz
add test, except from ydisk
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fec3ff22e3d7..f7035b885620 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yd-go-git
pkgdesc = Panel indicator for Yandex-disk CLI daemon (linux)
pkgver = master.5af17d8.r0.g5af17d8
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/slytomcat/yd-go/
arch = x86_64
license = GPL-3.0-only
diff --git a/PKGBUILD b/PKGBUILD
index 0603105f1fca..01e83ae5f88c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="yd-go-git"
_pkgname=${pkgname%-git}
-pkgrel=6
+pkgrel=7
pkgver="master.5af17d8.r0.g5af17d8"
pkgdesc="Panel indicator for Yandex-disk CLI daemon (linux)"
arch=('x86_64')
@@ -57,17 +57,18 @@ build() {
}
#Test yd-go
-#check() {
- #echo "Test yd-go..."
- #cd "${srcdir}/${_pkgname}"
- #go test ./...
-#}
+check() {
+ echo "Test yd-go..."
+ cd "${srcdir}/${_pkgname}"
+ go test ./icons/
+ go test ./notify/
+ go test ./tools/
+ #go test ./ydisk/
+}
package() {
echo "Install yd-go..."
install -Dm755 "${srcdir}/${_pkgname}/build/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -Dm644 "${srcdir}/${_pkgname}/icons/img/yd128.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
- #TODO: add autostart in $XDG_CONFIG_DIRS/autostart
- # Autostart spec.: https://specifications.freedesktop.org/autostart-spec/autostart-spec-latest.html
}