summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2023-04-16 20:11:33 +0300
committerFelix Yan2023-04-16 20:11:33 +0300
commit1a164aa5adc3213755a4f3ec2b2b1a4a84aae28f (patch)
tree1c5caae70930c4e3425e6ec5b80c34d3d780f02f
downloadaur-1a164aa5adc3213755a4f3ec2b2b1a4a84aae28f.tar.gz
import from community
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7acf497d651d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ydcv
+ pkgdesc = YouDao Console Version - Simple wrapper for Youdao online translate (Chinese <-> English) service API, as an alternative to the StarDict Console Version (sdcv)
+ pkgver = 0.7
+ pkgrel = 7
+ url = https://github.com/felixonmars/ydcv
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools-scm
+ makedepends = python-setuptools-markdown
+ depends = python
+ source = git+https://github.com/felixonmars/ydcv.git#commit=bd73c0a0b09587ef64794c593253a5b464e2e52e
+ sha512sums = SKIP
+
+pkgname = ydcv
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6c2cac81640
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor : Fernando "Firef0x" G.P. da Silva <firefgx { aT ) gmail [ d0t } com>
+
+pkgname=ydcv
+pkgdesc="YouDao Console Version - Simple wrapper for Youdao online translate (Chinese <-> English) service API, as an alternative to the StarDict Console Version (sdcv)"
+pkgver=0.7
+_commit=bd73c0a0b09587ef64794c593253a5b464e2e52e
+pkgrel=7
+arch=("any")
+url="https://github.com/felixonmars/ydcv"
+license=("GPL")
+depends=('python')
+makedepends=('git' 'python-setuptools-scm' 'python-setuptools-markdown')
+source=("git+https://github.com/felixonmars/ydcv.git#commit=$_commit")
+sha512sums=('SKIP')
+
+package() {
+ cd ydcv
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 contrib/zsh_completion "$pkgdir"/usr/share/zsh/site-functions/_$pkgname
+}
+
+# vim:set ts=2 sw=2 et: